Connection attempt to www.zdnet.com times out

VERIFIED DUPLICATE of bug 120025

Status

()

VERIFIED DUPLICATE of bug 120025
17 years ago
16 years ago

People

(Reporter: fuzzygorilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When trying to view ZDnet URLs, the browser pops up an alert, reporting "The
operation times out when attempting to contact
www.zdnet.com.".

There is no HTTP proxy in use.

I am able to ping www.zdnet.com so I know that routing is not the
issue.

MSIE6 from a VMware session running on the same Linux host is able
to connect to www.zdnet.com, so I know the server is not the issue.

I have quit the browser and restarted with no change in behavior.

Reproducible: Always
Steps to Reproduce:
1.Select 'File' 'Open Web Location...'
2.Enter 'http://www.zdnet.com/'
3.Select 'Open in: New Navigator Tab' and 'Open'

Actual Results:  The Alert appears announcing the timeout.

Expected Results:  The home page should have appeared.

I quit the browser and set the NSPR_LOG_MODULES and NSPR_LOG_FILE
environment variables.

export NSPR_LOG_MODULES=nsHttp:5
export NSPR_LOG_FILE=http.log

I will attach the resulting log file separately.
(Reporter)

Comment 1

17 years ago
I tried to attach the log file, but every time I tried, Bugzilla reported:

Error
You did not specify a file to attach.
Please press Back and try again.

Which seems strange since I used 'Browse' to select the file to attach.
I will cut'n'paste it instead.  Sorry.
(Reporter)

Comment 2

17 years ago
1024[8087eb0]: Creating nsHttpHandler [this=8183820].
1024[8087eb0]: nsHttpHandler::Init
1024[8087eb0]: nsHttpHandler::PrefsChanged [pref=(null)]
1024[8087eb0]: nsHttpAuthCache::Init
1024[8087eb0]: nsHttpHandler::NewURI
1024[8087eb0]: nsHttpHandler::NewProxiedChannel [proxyInfo=0]
1024[8087eb0]: Creating nsHttpChannel @877f708
1024[8087eb0]: nsHttpChannel::Init [this=877f708]
1024[8087eb0]: host=www.zdnet.com port=-1
1024[8087eb0]: uri=http://www.zdnet.com/
1024[8087eb0]: Creating nsHttpConnectionInfo @877f848
1024[8087eb0]: nsHttpHandler::AddStandardRequestHeaders
1024[8087eb0]: nsHttpHandler::BuildUserAgent
1024[8087eb0]: nsHttpChannel::AddAuthorizationHeaders? [this=877f708]
1024[8087eb0]: nsHttpAuthCache::GetAuthEntryForPath [host=www.zdnet.com:80 path=
/]
1024[8087eb0]: nsHttpChannel::AsyncOpen [this=877f708]
1024[8087eb0]: nsHttpHandler::OnModifyRequest [chan=877f708]
1024[8087eb0]: nsHttpChannel::SetRequestHeader [this=877f708 header=Cookie value
=]
1024[8087eb0]: CreateAtomTable
1024[8087eb0]: nsHttpChannel::Connect [this=877f708]
1024[8087eb0]: nsHttpChannel::OpenCacheEntry [this=877f708]
1024[8087eb0]: got cache entry [access=2]
1024[8087eb0]: nsHTTPChannel::CheckCache [this=877f708 entry=879a4e0]
1024[8087eb0]: Creating nsHttpTransaction @879d6b8
1024[8087eb0]: nsHttpTransaction::SetupRequest [this=879d6b8]
1024[8087eb0]: http request [
1024[8087eb0]:   GET / HTTP/1.1
1024[8087eb0]:   Host: www.zdnet.com
1024[8087eb0]:   User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) 
Gecko/20020417
1024[8087eb0]:   Accept: text/xml,application/xml,application/xhtml+xml,text/htm
l;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/c
ss,*/*;q=0.1
1024[8087eb0]:   Accept-Language: en-us, en;q=0.50
1024[8087eb0]:   Accept-Encoding: gzip, deflate, compress;q=0.9
1024[8087eb0]:   Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
1024[8087eb0]:   Keep-Alive: 300
1024[8087eb0]:   Connection: keep-alive
1024[8087eb0]: ]
1024[8087eb0]: nsHttpHandler::InitiateTransaction
1024[8087eb0]: nsHttpHandler::GetConnection_Locked
1024[8087eb0]: nsHttpHandler::AtActiveConnectionLimit_Locked [host=www.zdnet.com
:80 caps=1]
1024[8087eb0]:    total-count=0, persistent-count=0
1024[8087eb0]: >> creating new connection...
1024[8087eb0]: Creating nsHttpConnection @879d780
1024[8087eb0]: nsHttpConnection::Init [this=879d780]
1024[8087eb0]: nsHttpHandler::DispatchTransaction_Locked [trans=879d6b8 conn=879
d780]
1024[8087eb0]: nsHttpConnection::SetTransaction [this=879d780 trans=879d6b8]
1026[81773d8]: nsHttpTransaction::OnStatus [this=879d6b8 status=804b0003]
1026[81773d8]: nsHttpTransaction::OnStatus [this=879d6b8 status=804b0007]
1026[81773d8]: nsHttpConnection::OnStartRequest [this=879d780]
1026[81773d8]: nsHttpConnection::OnStopRequest [this=879d780 ctxt=0 status=804b0
00e]
1026[81773d8]: nsHttpConnection::OnStartRequest [this=879d780]
1026[81773d8]: nsHttpConnection::OnStopRequest [this=879d780 ctxt=879d784 status
=804b000e]
1026[81773d8]: nsHttpTransaction::OnStopTransaction [this=879d6b8 status=804b000
e]
1026[81773d8]: nsHttpHandler::ReclaimConnection [conn=879d780(www.zdnet.com:80) 
keep-alive=0]
1026[81773d8]: closing connection: connection can't be reused
1026[81773d8]: active connection count is now 0
1026[81773d8]: nsHttpHandler::ProcessTransactionQ_Locked
1026[81773d8]: >> unable to process transaction queue at this time
1024[8087eb0]: nsHttpChannel::OnStartRequest [this=877f708 request=879d6bc statu
s=804b000e]
1024[8087eb0]: nsHttpChannel::OnStopRequest [this=877f708 request=879d6bc status
=804b000e]
1024[8087eb0]: nsHttpChannel::FinalizeCacheEntry [this=877f708]
1024[8087eb0]: nsHttpChannel::CloseCacheEntry [this=877f708 status=804b000e]
1024[8087eb0]: dooming cache entry!!
1024[8087eb0]: nsHttpHandler::NewURI
1024[8087eb0]: nsHttpTransaction::DeleteSelfOnConsumerThread [this=879d6b8]
1024[8087eb0]: proxying delete to consumer thread...
1024[8087eb0]: nsHttpTransaction::DeleteThis_EventHandlerFunc [trans=879d6b8]
1024[8087eb0]: Destroying nsHttpTransaction @879d6b8
1024[8087eb0]: Destroying nsHttpConnection @879d780
1024[8087eb0]: Destroying nsHttpChannel @877f708
1024[8087eb0]: Destroying nsHttpConnectionInfo @877f848
1024[8087eb0]: Deleting nsHttpHandler [this=8183820]
1024[8087eb0]: dropping active connections...
1024[8087eb0]: dropping idle connections...
1024[8087eb0]: nsHttpAuthCache::ClearAll

Comment 3

17 years ago
WFM using 1.0RC1 on KDE 2.2.2.
Opened immediately.
wfm, Linux, 1.0RC1
(Reporter)

Comment 5

17 years ago
Further research has isolated the problem.  The system is using a Debian Linux
2.4.17 kernel.  This kernel has Explicit Congestion Notification (ECN) for TCP
enabled by default ('cat /proc/sys/net/ipv4/tcp_ecn').  The problem is that a
ZDnet has equipment that is not compatible with ECN for TCP/IP
( http://www.icir.org/floyd/ecnProblems.html )  Disabling ECN in the kernel
allowed Mozilla to reach www.zdnet.com ('echo "0" > /proc/sys/net/ipv4/tcp_ecn').
I will try to contact ZDnet to let them know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Catching up.  If this is still a problem, please reopen bug.  Thanks!  Marking
Verified.
Status: RESOLVED → VERIFIED
QA Contact: benc → jimmylee

Comment 7

16 years ago
REOPEN: this is a dupe of another bug
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

16 years ago
jimmy, can you read the other bug and verify if you agree?

*** This bug has been marked as a duplicate of 120025 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
Build: 2002-11-04-08-trunk(WIN)

I'm tempted to simply reopen this bug, but I'm not getting any time out.  What I
am getting is a very, very slow page opening.  I can see this on both Linux and
Windows.  I will check a bit later to see if I can reproduce.  If yes, then I'm
going to submit a new bug describing what I see.

Marking this one verified.
Status: RESOLVED → VERIFIED

Comment 10

16 years ago
For those interested, http://www.zdnet.com/ now opens quickly.  There may have
been some traffic earlier or something.
You need to log in before you can comment on or make changes to this bug.