If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RWD with W820 should match the spec

RESOLVED DUPLICATE of bug 1388796

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1388796
26 days ago
22 days ago

People

(Reporter: Hani Yacoub, Unassigned)

Tracking

(Blocks: 1 bug)

57 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 unaffected, firefox56 unaffected, firefox57 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

26 days ago
Created attachment 8900676 [details]
820.png

[Affected versions]: 
Nightly 57.0a1

[Affected platforms]:
Platforms: Windows 10 x 64 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox.
2. Go to "about:preferences".
3. Change the W to 820.

[Expected result]:
The distance between content area and scroll bar doesn't match the spec.

[Actual result]:
The distance between content area and scroll bar should match the spec.
(Reporter)

Updated

26 days ago
Blocks: 1357306
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
Whiteboard: [photon-preference][triage]

Comment 1

26 days ago
Hi Hani,

I think we should remove the scroll of category menu list in this bug.

But I don't know what do you mean "The distance between" here.

Thank you.
Flags: needinfo?(hani.yacoub)
(In reply to Evan Tseng [:evanxd] from comment #1)
> I think we should remove the scroll of category menu list in this bug.

These unexpected scrollbars in category menu and panel content will be removed in bug 1391646.
(In reply to Hani Yacoub from comment #0)
> [Expected result]:
> The distance between content area and scroll bar doesn't match the spec.
> 
> [Actual result]:
> The distance between content area and scroll bar should match the spec.

Hani, at the time reporting expect/actual result, can you describe more details about what you expect? We've a bit confused by what you mentioned "should match the spec" and also all of those RWD relevant bugs. Perhaps you can try to draw some arrow indicators on picture and then list down unmatched UI components on bug comment.
(Reporter)

Comment 4

25 days ago
Created attachment 8901051 [details]
N820.png

I was referring to the distance indicated in this screenshot.
The distance on Windows is different comparing to Mac OS/Ubuntu 16.04 or comparing with the spec.
Thanks.
Flags: needinfo?(hani.yacoub)

Comment 5

25 days ago
Created attachment 8901060 [details]
width-820px-preferences.png

(In reply to Hani Yacoub from comment #4)
> Created attachment 8901051 [details]
> N820.png
> 
> I was referring to the distance indicated in this screenshot.
> The distance on Windows is different comparing to Mac OS/Ubuntu 16.04 or
> comparing with the spec.
> Thanks.

Hi Hani,

The attachment is the screen of Preferences page with 820px width but it doesn't show the issue you mentioned in this bug.

Are you sure your width is 820px, you could use debugger to ensure that just like the screenshot did.

Thank you.

Updated

25 days ago
Flags: needinfo?(hani.yacoub)
(Reporter)

Comment 6

25 days ago
Created attachment 8901062 [details]
820 new.png

I am using debugger to change the Preferences page width to 820px.
Flags: needinfo?(hani.yacoub)

Comment 7

25 days ago
Bug 1388796 and Bug 1392532 might fix issue. Let's verify it again after they're landed.
Depends on: 1388796, 1392532

Updated

22 days ago
Status: NEW → RESOLVED
Last Resolved: 22 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388796

Comment 9

22 days ago
remove whiteboard tag due to its DUPLICATE
Whiteboard: [photon-preference][triage]
You need to log in before you can comment on or make changes to this bug.