MDN page cannot be autoscrolled up/down

RESOLVED INVALID

Status

()

Core
Panning and Zooming
RESOLVED INVALID
5 months ago
5 months ago

People

(Reporter: petruta, Unassigned)

Tracking

5 Branch
Points:
---

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

(Reporter)

Description

5 months ago
[Affected versions]:
- Nightly 57.0a1 2017-08-23
- Firefox 56.0b5
- Firefox 55.0.3

[Affected platforms]:
- Win 10 64-bit
- Ubuntu 16.04 64-bit
Mac OS X 10.12

[Steps to reproduce]:
1. Open https://developer.mozilla.org/en-US/Firefox/Experimental_features
2. Middle mouse click to autoscroll the page
3. Refresh the page and repeat step 2

[Expected result]:
- The page can be autoscrolled up/down and right/left

[Actual result]:
- Only right/left arrows are displayed on the autoscroll icon. Up/down autoscrolling is not performed.

[Regression range]:
- This is not a regression, it reproduces back to Firefox 4.0.1.
(In reply to Petruta Rasa [QA] [:petruta] from comment #0)
> [Steps to reproduce]:
> 1. Open https://developer.mozilla.org/en-US/Firefox/Experimental_features
> 2. Middle mouse click to autoscroll the page
> 3. Refresh the page and repeat step 2

Refreshing the page is not necessary, but you have to middle-click while over your mouse is over top of the main content area. When you first load the page there's a big "Why does MDN look different" box at the top which means the content is shifted down, so you'd have to scroll down to middle-click on the content area and repro the problem.

That being said, this looks like intentional behaviour. When you click inside the main content area the innermost scrollable frame is only horizontally scrollable so that's what is available for autoscroll. If you middle-click on the left or right margin of the page you get vertical autoscroll because that's outside the inner scrollable. If you scroll all the way down to the bottom of the page you can see the horizontal scrollbar for the inner scrollable frame and what is getting scrolled.

I'm going to close this as invalid on the grounds that this is expected behaviour.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.