Crash in java.lang.NullPointerException: Attempt to invoke virtual method ''int android.content.Intent.getIntExtra(java.lang.String, int)'' on a null object reference at android.support.v4.content.WakefulBroadcastReceiver.completeWakefulIntent(Unknown ...

RESOLVED DUPLICATE of bug 1396604

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1396604
11 months ago
11 months ago

People

(Reporter: marcia, Assigned: JanH)

Tracking

({crash})

55 Branch
crash
Points:
---

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

(crash signature)

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 months ago
This bug was filed from the Socorro interface and is 
report bp-a223a59d-8a91-4ca4-b62f-b33e10170817.
=============================================================

Not sure where to bucket this, because I don't see a stack in many of the reports. This showed up on the release explosiveness report, but affects other branches as well: http://bit.ly/2wrk8U5

Affects a wide spectrum of devices and APIs.

Comments:
thanks - it just crashed - no reason that I know of. 
I am removing program. obviously doesn't work with Android
(Reporter)

Comment 1

11 months ago
Adding snorp and nevin - I don't know where this crash belongs...
Flags: needinfo?(snorp)
Flags: needinfo?(cnevinchen)
Looks like frontend to me.
Flags: needinfo?(snorp)
(Assignee)

Comment 3

11 months ago
The fix is easy, but on a side note - as far as I can see the FeedService was intended to support content notifications for bookmarked pages, which have been disabled (and apparently forgotten about) since last year.
Assignee: nobody → jh+bugzilla
Flags: needinfo?(cnevinchen)
Hi Sebastian
I don't see any problem with this code. (Although completeWakefulIntent will be deprecated in 26.
Maybe we can move out null check before finally
http://searchfox.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/feeds/FeedService.java#72
but I can think of a situation that onHandleIntent will pass in a null intent!


I remember last time you showed us it's still working. 
But today I've installed the https://addons.mozilla.org/en-US/android/addon/home-feeds/ but can't find a rss feed to test..
Could you give me some hint? Thanks!
Assignee: jh+bugzilla → nobody
Flags: needinfo?(s.kaspari)
Comment hidden (mozreview-request)
(Assignee)

Updated

11 months ago
Assignee: nobody → jh+bugzilla
The content notifications experiment is disabled. Can anyone of you investigate why this code is running at all?
Flags: needinfo?(s.kaspari)
(Assignee)

Comment 7

11 months ago
@Nevin: The Home Feeds add-on is unrelated. As far as I can see, it just implements an RSS reader that shows its contents as a home panel and was last updated in 2014, i.e. two years before the FeedService was added.

@Sebastian: Because the Switchboard experiment only turns off the notifications and the hides the setting in our preferences, but not doesn't do anything for the FeedService itself. We still initialise it (https://dxr.mozilla.org/mozilla-central/search?q=path%3Amobile+feedservice+setup), which in turn schedules some daily feed maintenance tasks (https://dxr.mozilla.org/mozilla-central/rev/4caca1d0ba0e35cbe57a88493ebf162aa2cb3144/mobile/android/base/java/org/mozilla/gecko/feeds/action/SetupAlarmsAction.java#37).
Those (enroll/withdraw) are controlled only be the pref, which
a) defaults to "true" if not explicitly set (https://dxr.mozilla.org/mozilla-central/rev/4caca1d0ba0e35cbe57a88493ebf162aa2cb3144/mobile/android/base/java/org/mozilla/gecko/feeds/FeedService.java#165), and
b) checking on my Release profile, somehow ended up being explicitly set to "true" anyway.
Depends on: 1396604

Comment 8

11 months ago
mozreview-review
Comment on attachment 8900844 [details]
Bug 1393452 - Don't crash when FeedService is restarted after being killed.

https://reviewboard.mozilla.org/r/172294/#review181048
Attachment #8900844 - Flags: review?(s.kaspari)
I filed bug 1396604 to remove this code completely. There's no need to run and maintain this code anymore.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1396604
(Assignee)

Updated

11 months ago
Attachment #8900844 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.