Expose the full TP UI preferences

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: francois, Assigned: francois)

Tracking

unspecified
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 58+, firefox57blocking verified, firefox58 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
As a first step towards exposing this to everyone in release, we will show the full TP preferences in Beta.
Flags: qe-verify+
(Assignee)

Comment 1

2 years ago
This will be done either via a system add-on or Shield, to test the mechanism that will be used for the 57 rollout.

Decision on which mechanism to use will be made by 2017-09-11.
(Assignee)

Comment 2

2 years ago
Let's do this as a Shield experiment to test the rollout on release 57.
Summary: Enable the full TP UI preferences in Beta → Enable the full TP UI preferences in Beta 57
(Assignee)

Comment 3

2 years ago
Assigning to Peter since this is now a simple matter of sending an email once we have approval.
Assignee: francois → pdolanjski
(Assignee)

Comment 4

a year ago
Pending the results of the roll-out to release in 57, we will likely want to expose the UI pref to everyone starting in Beta 58, directly in the code.

Given the timing of the 57 experiment, this will need to be uplifted in 58.
Assignee: pdolanjski → francois
No longer blocks: 1387681
Depends on: 1393628
Keywords: stale-bug
Summary: Enable the full TP UI preferences in Beta 57 → Enable the full TP UI preferences in 58
(Assignee)

Comment 5

a year ago
[Tracking Requested - why for this release]: We have approval from Mayo to do this for 100% of users on day 1 of 57.
tracking-firefox57: --- → ?
Summary: Enable the full TP UI preferences in 58 → Expose the full TP UI preferences
Comment hidden (mozreview-request)

Comment 7

a year ago
mozreview-review
Comment on attachment 8925119 [details]
Bug 1393627 - Expose the full tracking protection UI preferences.

https://reviewboard.mozilla.org/r/196362/#review201542
Attachment #8925119 - Flags: review?(dtownsend) → review+
(Assignee)

Updated

a year ago
Blocks: 1387681
After conversation with Selena, marking this as a 57 blocker. Pref flip for 57 release.
status-firefox57: --- → affected
tracking-firefox57: ? → blocking
Ritu, n-i to make sure you are aware. It is late to test this, but sounds like this is just to show the prefs (not to have them be on by default).
Flags: needinfo?(rkothari)
(Assignee)

Comment 10

a year ago
The test plan is simply:

1. In a new profile, open about:preferences#privacy.
2. Scroll down to the Tracking Protection section.
3. Verify that it's a radio button with three options (always, only in private windows, never) instead of a checkbox.
Hi Francois, would you be able to comment on the study results from beta57? While the risk of showing this pref (not turning it on by default) in 57 is low, are we certain that for users that choose to turn the pref on there are no crashes/hangs/severe problems? Could you please confirm that? Thanks!
Flags: needinfo?(rkothari) → needinfo?(francois)
(Assignee)

Comment 12

a year ago
Other than the known issues with tracking protection (https://bugzilla.mozilla.org/show_bug.cgi?id=trackingprotection), I'm not aware of anything.

Matt, is there anything to worry about that came out of the beta57 study?
Flags: needinfo?(francois) → needinfo?(mgrimes)

Comment 13

a year ago
Pushed by fmarier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/516690579442
Expose the full tracking protection UI preferences. r=mossop
Thanks Francois. Please nominate this patch for uplift to Beta, will include it in RC1.
Flags: needinfo?(francois)
(Assignee)

Comment 15

a year ago
Comment on attachment 8925119 [details]
Bug 1393627 - Expose the full tracking protection UI preferences.

Approval Request Comment
[Feature/Bug causing the regression]: Not a regression, but a last minute product decision.
[User impact if declined]: No ability to enable tracking protection outside of private browsing.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: See comment 10.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No.
[Why is the change risky/not risky?]: It's just changing the default value of a single pref so that it matches the way it's been on Nightly for a few years.
[String changes made/needed]: No in-product string changes needed, but SUMO page needs to be updated to reflect this (bug 1409192).
Flags: needinfo?(francois)
Attachment #8925119 - Flags: approval-mozilla-beta?
(In reply to François Marier [:francois] from comment #12)
> Other than the known issues with tracking protection
> (https://bugzilla.mozilla.org/show_bug.cgi?id=trackingprotection), I'm not
> aware of anything.
> 
> Matt, is there anything to worry about that came out of the beta57 study?

Ilana is currently working on analysis for this study. She's in a better position to comment on that, but I don't know how close she is to being done.
Flags: needinfo?(mgrimes) → needinfo?(isegall)
https://hg.mozilla.org/mozilla-central/rev/516690579442
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8925119 [details]
Bug 1393627 - Expose the full tracking protection UI preferences.

It's a product decision to take this in 57. This should be in 57 RC1
Attachment #8925119 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 20

a year ago
Build ID: 20171106100122
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

I verified this issue on the latest nightly on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64 and I confirm that radio buttons are now displayed with three options (always, only in private windows, never) instead of a checkbox.

However on Ubuntu 16.04 the filling of radio button is black and on Windows and macOS the filling is blue, should I consider this an issue? (Please see the screenshot attached)

Thanks.
Flags: needinfo?(francois)
This bug is also verified on 57.0-build1 (20171106194249) using Windows 7 x64, Windows 10 x64, Ubuntu 16.04 x64	and macOS 10.13, but the behavior mentioned above by Hani is reproducible on Fx 57, too.

Comment 22

a year ago
(In reply to Matt Grimes [:Matt_G] from comment #16)
> (In reply to François Marier [:francois] from comment #12)
> > Other than the known issues with tracking protection
> > (https://bugzilla.mozilla.org/show_bug.cgi?id=trackingprotection), I'm not
> > aware of anything.
> > 
> > Matt, is there anything to worry about that came out of the beta57 study?
> 
> Ilana is currently working on analysis for this study. She's in a better
> position to comment on that, but I don't know how close she is to being done.

I am still working on the study given bugs we've encountered with data collection, and will keep everyone updated.
Flags: needinfo?(isegall)
(Assignee)

Comment 23

a year ago
(In reply to Hani Yacoub from comment #20)
> However on Ubuntu 16.04 the filling of radio button is black and on Windows
> and macOS the filling is blue, should I consider this an issue? (Please see
> the screenshot attached)

There's probably no time to fix it in 57, but it's possible it's also meant to be this way.

Johann, do you know if that's intended?
Flags: needinfo?(francois) → needinfo?(jhofmann)
Uh, I'm not sure, you should probably file a bug on it to be certain.

It was definitely not regressed by this bug, in any case.
Flags: needinfo?(jhofmann)

Comment 25

a year ago
Changing the tracking flags on firefox58 and firefox57 to verified.
I logged a bug regarding the issue mentioned above Bug 1415471.
status-firefox57: fixed → verified
status-firefox58: fixed → verified

Updated

a year ago
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Added to Fx58 release notes.
relnote-firefox: --- → 58+
You need to log in before you can comment on or make changes to this bug.