uMatrix WE icon disappears from the navigation bar when new tab is open

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
9 months ago
9 months ago

People

(Reporter: ajfhajf, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8901068 [details]
Disappeared icon

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170824100243

Steps to reproduce:

I've already reported this bug to Gorhill in uMatrix thread on mozilla.org and Gorhill hasn't released a fix so I assume the problem is on FF side.

Create new profile, install latest uMatrix beta from AMO:
https://addons.mozilla.org/en-US/firefox/addon/umatrix/versions/beta

Open new tab


Actual results:

uMatrix icon disappeared from the navigation bar


Expected results:

uMatrix icon should stay visible. There are two errors related to uMatrix in the browser console, the one is “Unknown localization message popuptipdashboard”, another “matrixSnapshot.usersettings is undefined”. Screenshot attached. Screenshots of the browser console available here: http://imgur.com/a/Br2Kd
An issue in a specific extension cannot be solved on Firefox side :(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 months ago
Atlanto from mozillazine has found a source of the problem:
http://forums.mozillazine.org/viewtopic.php?p=14763169#p14763169
>uMatrix(1.0.1b6) has no default icon.
>It is declared as "icon19.png",
>but there is no such file in uMatrix@raymondhill.net.xpi.
This bug is fixed in uMatrix 1.0.1rc0 so I change resolution to Fixed.
You need to log in before you can comment on or make changes to this bug.