Closed Bug 1393704 Opened 2 years ago Closed 2 years ago

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_gdata_provider.js | xpcshell return code: 0

Categories

(Calendar :: General, defect, P1, major)

Lightning 5.8

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1396897

People

(Reporter: jorgk-bmo, Assigned: Fallen)

References

Details

(Whiteboard: [Thunderbird-testfailure: X all][Thunderbird-disabled-test])

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_gdata_provider.js | xpcshell return code: 0 
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_gdata_provider.js | test_recurring_exception - [test_recurring_exception : 1183] 0 == 1

TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_gdata_provider.js | xpcshell return code: 0 
TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_gdata_provider.js | test_recurring_exception - [test_recurring_exception : 1183] 0 == 1

First seen Fri Aug 25, 2017, 8:29:55

M-C last good: 32674de9af80667006ab1a4efcdc70115f
M-C first bad: 2306e153fba9ca55726ffcce889eaca7a4

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=32674de9af80667006ab1a4efcdc70115f&tochange=2306e153fba9ca55726ffcce889eaca7a4

Point of failure:
https://dxr.mozilla.org/comm-central/rev/7b75c2e0b9deb590c18aaddb2a6168146cde8ca4/calendar/test/unit/test_gdata_provider.js#1183
Whiteboard: [Thunderbird-testfailure: X all]
I ran this locally and couldn't work out why this is failing now. Looks like getAllItems() from
https://dxr.mozilla.org/comm-central/rev/7b75c2e0b9deb590c18aaddb2a6168146cde8ca4/calendar/base/modules/calAsyncUtils.jsm#34
isn't working as expected. But that's advanced promise handling far away from my field of expertise.

With the range given in comment #0 the skilled eye might see the regression.

Arai any insights? Otherwise I have to refer this to the calendar people.
Flags: needinfo?(philipp)
Flags: needinfo?(makemyday)
Flags: needinfo?(arai.unmht)
Flags: needinfo?(Mozilla)
I tried backing out https://hg.mozilla.org/mozilla-central/rev/e63b09da86eb from bug 1393053 since that had "promise" in commit message, but that didn't help.
Comment on attachment 8901146 [details] [diff] [review]
1393704-disable-partof-test_gdata_provider.patch

r+ on the disable to unblock you, I'll have to take a closer look at this some time. I suspect it is some race condition issue.
Attachment #8901146 - Flags: review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/bfb0e8a1e5a2
temporarily disable failing part of test_recurring_exception in test_gdata_provider.js. r=philipp DONTBUILD
seems to be from the following changeset.
https://hg.mozilla.org/mozilla-central/rev/df5b4f5fe775

not sure how it affects tho.
Flags: needinfo?(arai.unmht)
Whiteboard: [Thunderbird-testfailure: X all] → [Thunderbird-testfailure: X all][Thunderbird-disabled-test]
I have to clear out this needinfo, since I don't have any stakes in the gdata-provider.
Flags: needinfo?(Mozilla)
Version: Trunk → Lightning 5.8
Assignee: nobody → philipp
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P1
Will be fixed by this bug:
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(philipp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1396897
Flags: needinfo?(makemyday)
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.