NSS Android build fails with undefined reference to 'getdtablesize'

RESOLVED DUPLICATE of bug 1370138

Status

NSS
Build
RESOLVED DUPLICATE of bug 1370138
10 months ago
10 months ago

People

(Reporter: Gautam Prajapati, Unassigned)

Tracking

3.29

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8901099 [details] [diff] [review]
nss.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

LibreOffice moved away from deprecated GCC toolchain in Android NDK. When built with Clang toolchain, NSS build fails with the error:

./unix_rand.c:744: error: undefined reference to 'getdtablesize'



Actual results:

Build failed with undefined reference to a function


Expected results:

Build should have succeeded considering that Clang is drop-in replacement for GCC
(Reporter)

Comment 1

10 months ago
I have attached the patch(nss.patch) which defines the "getdtablesize" and hence should solve this issue.
(Reporter)

Comment 2

10 months ago
I see that not just Clang but using GCC with latest NDK fails because "getdtablesize" has been removed on Android 21.
See: https://issuetracker.google.com/issues/37001193

Comment 3

10 months ago
Current upstream doesn't use getdtablesize now.  What NSS version for this patch?
Flags: needinfo?(gautamprajapati06)
(Reporter)

Comment 5

10 months ago
(In reply to Makoto Kato [:m_kato] from comment #3)
> Current upstream doesn't use getdtablesize now.  What NSS version for this
> patch?

Oh, I have set the version as 3.29. I'll try to upgrade the NSS in LO. Thanks. 
Closing the bug as Duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(gautamprajapati06)
Resolution: --- → DUPLICATE
Duplicate of bug: 1370138
You need to log in before you can comment on or make changes to this bug.