Closed Bug 1393724 Opened 4 years ago Closed 4 years ago

Games stop responding when I switch tabs

Categories

(Core :: Plug-ins, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1391247

People

(Reporter: chiara20001, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: flashplayer, regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170814072924

Steps to reproduce:

1. I opened the Firefox, and then opened a game. In fact, some MMO games to reproduce with.
2. I started loading the MMO games. After it was fully loaded, and ensuring the game can respond to my clicks, I switched tabs.
3. I then switched back to the game. I tried clicking somewhere on the game.


Actual results:

The game stopped responding, but in a strange way. The game still work fine as usual, but when I click on somewhere in the game, the game doesn't register my clicks.
What I mean: normally without switching tabs, the game can respond to the clicks, at least it's for my problem. But, when I switch tabs, and then return to the game, the game still works, runs fine. What actually happens is that the game stops registering my clicks, and therefore, the game seems softlocked. However, it can be fixed by opening the Analyze Elements and then closing it. But it's really annoying, and it's not just ONE MMO game- even since the update, I've been having this annoying issue for some games. It's happened to me in these MMO games: Dawnbreaker Online, and Divine Storm.


Expected results:

The games should have still responded, and should have still registered my clicks, even after switching tabs. Even since the newest Firefox update, it has negated this.
It should also be added that some peoples may also experience this issue with certain MMO games. This reproduction of issue only worked for me, I'm not sure if I'm the only one.
Component: Untriaged → Plug-ins
Keywords: flashplayer
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1276426
Sorry, was mistake.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Blocks: 1394408
I want to add that, after reinstalling Firefox, it fixed this problem. I felt like I needed to state/confirm this statement. But, it hasn't been fixed. I'm wishing this bug could be fixed with a update, without having to reinstall Firefox.

At least, on the bright side, I didn't lose any data on Firefox.
Hi, can you provide a link to the game that had the issue?
Flags: needinfo?(chiara20001)
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391247
Flags: needinfo?(chiara20001)
You need to log in before you can comment on or make changes to this bug.