[RFE] New Bookmark in Context Menu for Bookmark Folders

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Roger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/00200203
BuildID:    Mozilla 1.0 Release Candidate 1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/00200203

When editing books marks, there's only one way to add a bookmark and that is by
doing "manage bookmarks" > File > New > bookmark.

You apperantly cannot simply right click on the folder where you want a new
bookmark and right click and create it as there is no option at that point to
'create a bookmark'...but you can create a folder.

Reproducible: Always
Steps to Reproduce:
1a. manage bookmarks
 b. File > New > bookmark (You can create new blank bookmark this way)

2a. manage bookmarks
 b. right click on a folder and try to creat a new blank bookmark (no option to
do so!)

Actual Results:  nada

Expected Results:  to be able to create new blank bookmark anywhere in manage
bookmarks applet

(btw, the easy-to-add a new bug form works great. don't have to mess around
trying to decipher bugzilla anymore!...any user can submit a bug...lol)

Updated

16 years ago
Severity: minor → enhancement
OS: Linux → All
Hardware: PC → All
Summary: When editing books marks, there's only one way to add a bookmark → [RFE] New Bookmark in Context Menu for Bookmark Folders

Comment 1

16 years ago
*** Bug 140598 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Marking new to get off the unconfirm list.

I could not find a dup, but bug 135841 seems to be where the bookmark context
menu action is.

In addition, this feature does appear to be in the *ahem* specification:
http://www.mozilla.org/projects/ui/communicator/framework/contextmenus/cmrev2-3a.html#Anchor-Supported-30189
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
i dont think this is an enhancement, this is a quite severe bug. its very
confusing and annoying
*** Bug 162465 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 147785 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Duplicate of bug 85895 ?
Depends on: 85895
Re: Comment #2 From Andy Edmonds 2002-05-29 16:42
> Marking new to get off the unconfirm list.

What's the point in 'UNCONFIRMED' if you're confirming bugs just for the sake of
"getting them off the unconfirmed list"?

Re: Comment #3 From Michael Gabriel 2002-08-05 17:21
> i dont think this is an enhancement, this is a quite severe bug. its very
> confusing and annoying

I figure you're just as confused and annoyed when finding out that no context
menu of folders in Windows Explorer have such a 'New' item?

Re: Comment #6 From Andreas Kunz 2002-10-26 17:23 -------
> Duplicate of bug 85895 ?

No. Bug 85895 is about the same menu item for any bookmark manager and bookmark
sidebar contextual menus.

Anyway, I'll wontfix this. It just doesn't seem logical to me. I've just checked
various browsers and they do not have this menu item either. Additionally, there
hasn't been any comment of a developer wanting to implement this, so this
probably won't get fixed anyway.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 8

15 years ago
We have New Folder but not New Bookmark.  This doesn't make sense, as at least I
use New Bookmark more than New Folder.

Comment 9

15 years ago
In Bug 147785 the "new separator" command for the sidebar context menu was
mentioned. I think this would really be a good enhancement. And I don't see why
one should be able to create a new folder, but not a new separator.
--> I'd suggest to re-open this bug.

Comment 10

15 years ago
I'm going to re-open this.  Without the context menu, you have to create a
top-level bookmark and then drag it into the appropriate folder.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Product: Browser → Seamonkey

Comment 11

12 years ago
This is also a Netscape 4.x compatability issue. NS4 had a "New Bookmark" in the context menu if you right-clicked on a folder *or* a bookmark.

Jim H. (aka CuriousJ)
Assignee: bugs → nobody
Status: REOPENED → NEW
QA Contact: claudius → bookmarks

Comment 12

5 years ago
WFM here
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 15 years ago5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.