(photon) Status bar color does not change on all devices

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: oana.horvath, Unassigned)

Tracking

(Blocks: 2 bugs)

57 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: [FNC][SPT57.3][MVP])

User Story

Mobile Visual spec: https://drive.google.com/file/d/0B-9PIePlQZRldk9INm9TUXBkcWs/view
Tablet visual spec:
https://drive.google.com/file/d/0B-9PIePlQZRlSFdzc1BXVlA5bDA/view

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Build: Nightly 57.0a1 (2017-08-25);
Devices:
Prestigio Grace X5 (Android 4.4.2)
HTC Nexus 9 (Android 7.1.1)
Xiaomi Mi Pad 2 (Android 5.1)
Lenovo Yoga Tablet 2 (Android 4.4.2)
Asus ZenPad 8.0 Z380KL (Android 6.0.1)

Steps to reproduce:
1. Open Nightly and switch between normal & private browsing modes.
2. Observe the status bar color.

Expected result:
In normal browsing, the status bar should have the same color as Nightly's toolbar (white).
In private browsing, the status bar should have the same color as Nightly's toolbar (gray).

Actual result:
On the list of devices here, the status bar doesn't change color.
(Reporter)

Updated

a year ago
No longer blocks: 1376995

Updated

a year ago
Whiteboard: [FNC][SPT57.3][MVP]

Comment 1

a year ago
We only support changing status bar color when device version >= 23(Android 6.0) because it needs:

1. `Window#setStatusBarColor(int)` requires version >= 21, and
2. `View#SYSTEM_UI_FLAG_LIGHT_STATUS_BAR` requires version >= 23

Hi Oana, for all devices >= 23 you have, does only HTC Nexus 9 and Asus ZenPad 8.0 Z380KL have this issue? Could you give us snapshots for further investigation since we don't have any of them in Taipei office?
Flags: needinfo?(oana.horvath)
(Reporter)

Comment 2

a year ago
Created attachment 8903126 [details]
Asus.jpg

Yes, these 2 devices are the only ones that I have with this issue. I've attached the screenshots. Let me know if I can help you with more infos.
Flags: needinfo?(oana.horvath)
(Reporter)

Comment 3

a year ago
Created attachment 8903128 [details]
Nexus.png

Comment 4

a year ago
Hi Oana,

The status bar color in mobile and tablet are different, and the logic is

In mobile, the status bar color is white in normal mode, and grey in private mode;
In tablet, the status bar color is always grey in both mode.

This difference is by design because in tablet we have tab strips layout between status bar and toolbar. Since HTC Nexus 9 and Asus ZenPad 8.0 Z380KL are both tablets, it's correct to show grey status bar in normal mode. 

I've attached mobile/tablet visual spec links in 'User Story' for the reference.
User Story: (updated)
(Reporter)

Comment 5

a year ago
Thanks for clarifying! I'll mark this issue as invalid.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.