Closed Bug 1393773 Opened 4 years ago Closed 4 years ago

Drag out image from FF (w/ e10s - Multiprocess actived) saves without extension

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1389836

People

(Reporter: knotvoid, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170825100126

Steps to reproduce:

Drag out image from Firefox (ex. Firefox to desktop)
- e10s - Multiprocess activated (deactivated save correctly)


Actual results:

Saves file without extension


Expected results:

Save file with extension
can you provide the URL of the webpage where the issue happens?
Flags: needinfo?(knotvoid)
Any page. 

If the e10s is active the saved image  come without extension, if not the image comes correctly.
Flags: needinfo?(knotvoid)
tried with the following URL, with Nightly 57.0a1 (2017-08-25) (64-bit) with clean profile on macOS.
https://www.mozilla.org/media/img/logos/firefox/logo-wordmark-large-noshadow.bc14682067d3.png

dragging and dropping the image onto desktop downloads the image as "logo-wordmark-large-noshadow.bc14682067d3.png", and no issue happens.

also tried with the following URL
https://doc.rust-lang.org/book/second-edition/ch04-03-slices.html

dragging and dropping the Figure 4-12 onto desktop downloads the image as "trpl04-06.svg", and no issue happens.


please provide an example URL to reproduce the issue.
Flags: needinfo?(knotvoid)
Maybe a duplicate of Bug 1389836, but I cannot reproduce the issue either.
Component: Untriaged → Drag and Drop
Product: Firefox → Core
Can't reproduce either, but we should just track one bug.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389836
Flags: needinfo?(knotvoid)
Tooru Fujisawa [:arai]

I add more details on bug 1389836 page.
You need to log in before you can comment on or make changes to this bug.