Closed Bug 1393865 Opened 5 years ago Closed 5 years ago

Try syntax no longer schedules some jobs (e.g. web-platform-tests-wdspec)

Categories

(Firefox Build System :: Task Configuration, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla57

People

(Reporter: impossibus, Assigned: impossibus)

Details

(Keywords: regression)

Attachments

(1 file)

I used to be able to schedule web-platform-tests-wdspec like this: 

try: -b do -p linux64 -u marionette,web-platform-tests-wdspec -t none 

Worked on August 14: https://treeherder.mozilla.org/#/jobs?repo=try&revision=df9ccdab4ea8e35f9916e9363ddcf3f393d88e87

But not anymore. August 25: https://treeherder.mozilla.org/#/jobs?repo=try&revision=43aeb5b54a7539747d8a1640fc9699e89b7ff9be

When I used -u all, the wdspec job gets scheduled. 

I think maybe firefox-ui-functional-local and others have become broken as well.
Flags: needinfo?(ahalberstadt)
This is because Joel turned off all non-e10s tasks on linux, so try:
try: -b do -p linux64 -u marionette,web-platform-tests-wdspec-e10s -t none

For future reference you can debug stuff like this by using |mach try fuzzy|, though at that point you might as well just use |mach try fuzzy| to begin with :).

Also I'd agree that specifying 'web-platform-tests-wdspec' should schedule both e10s and non-e10s, so feel free to turn this bug into that (though I'm certainly not volunteering!)
Flags: needinfo?(ahalberstadt)
P.s, ./mach try fuzzy has a --preset/--save option now, so:
./mach try fuzzy -q "!cov !pgo 'wdspec" --save wdspec
./mach try --preset wdspec
Yep, web-platform-tests-wdspec-e10s works. 

I also noticed that web-platform-tests-reftests didn't break in this way: e10s tests are always scheduled regardless of whether there's an e10s suffix or not. The only difference in their config is that wpt-reftests is listed in UNITTEST_ALIASES in try_option_syntax. 

Indeed, adding the wdpsec identifiers there fixes the issue: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b74d43e7a07c08750176ab132258750a24f5978c

...that seems weird and unintentional.
Assignee: nobody → mjzffr
Comment on attachment 8901312 [details]
Bug 1393865 - Add try aliases for web-platform-tests-wdspec;

https://reviewboard.mozilla.org/r/172758/#review178186
Attachment #8901312 - Flags: review?(dustin) → review+
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/80c31aaac28f
Add try aliases for web-platform-tests-wdspec; r=dustin
https://hg.mozilla.org/mozilla-central/rev/80c31aaac28f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.