Intermittent dom/media/test/test_resolution_change.html | resolution-change.webm-0 timed out!

RESOLVED DUPLICATE of bug 1392747

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1392747
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

(Blocks 1 bug, {intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leave open][stockwell disabled])

Attachments

(1 attachment)

Flags: needinfo?(alwu)
Since its failure rate is super low, I think it's not worth to spend time investigating it. I'll prefer to wait for a long while to see its trend (still happen or disappear).
Flags: needinfo?(alwu)
alwu: I've re-enabled Mdm1 and at first glance this appears to be happening on Android 4.4. If it turns out to be common on 4.4, I'll disable it.

https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=autophone&fromchange=fa0f66eaa81fa9663de8e1d73f1299c585ef53f8&group_state=expanded&selectedJob=142439079
Flags: needinfo?(alwu)
I'm not working on Fennec test case now, transfer NI to John.
Flags: needinfo?(alwu) → needinfo?(jolin)
Attachment #8926841 - Flags: review?(gbrown) → review+
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/006b8806bac9
disable dom/media/test/test_resolution_change.html on Android 4.4 due to time outs, r=gbrown.
Whiteboard: [leave open][stockwell disabled]
The log shows media shutdown process timed out, just like bug 1392747:

11-20 15:30:25.872 I/Gecko   ( 6404): FATAL ERROR: AsyncShutdown timeout in profile-before-change Conditions: [{"name":"MediaShutdownManager: shutdown","state":"(none)","filename":"/builds/worker/workspace/build/src/dom/media/MediaShutdownManager.cpp","lineNumber":83,"stack":"MediaShutdownManager shutdown"}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jolin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1392747
You need to log in before you can comment on or make changes to this bug.