Intermittent autophone-crashtest-dom-media-tests | Test exited with return code 1

RESOLVED INCOMPLETE

Status

()

P5
normal
RESOLVED INCOMPLETE
a year ago
9 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

Reopening since failures are still occuring:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=141126637&filter-searchStr=07792d273026c743423a8d237fdc61fed6346be8
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
34 failures in 169 pushes (0.201 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 18
* mozilla-inbound: 16

Platform breakdown:
* android-4-4-armv7-api16: 13
* android-6-0-armv8-api16: 12
* android-7-1-armv8-api16: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-10-31&endday=2017-10-31&tree=all
:jolin, could you please take a closer look at these fails because in the last couple of days we've had a lot of them, also on central besides those on autoland and inbound. Thanks!

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-searchStr=cdm&fromchange=9af785de987dc546c9e792c593cacd7b9b68e8bc
Flags: needinfo?(jolin)
The unit test log looks similar to bug 1412394.
Depends on: 1412394
Flags: needinfo?(jolin)
105 failures in 180 pushes (0.583 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* mozilla-inbound: 42
* mozilla-central: 35
* autoland: 28

Platform breakdown:
* android-4-4-armv7-api16: 39
* android-7-1-armv8-api16: 33
* android-6-0-armv8-api16: 25
* android-5-0-armv8-api16: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-11-01&endday=2017-11-01&tree=all
Whiteboard: [stockwell needswork]

Comment 7

a year ago
Please note that this bug actually doesn't have anything to do with the recent Cdm2 failures. The original failure was due to the Intermittent autophone-crashtest-dom-media-tests | Test exited with return code 1 failure which didn't have a clear cause. Almost any crash or framework failure would result in "Test exited with return code 1". If there are additional error messages in the log, then those are more likely to be the actual bug rather than the generic "Test exited with return code 1".

The recent problems with Cdm2 are actually due to bug 1412394 which has the crash [@ mozilla::MediaManager::PostTask].

The error message "exited with return code 1" could be due to any number of reasons, but if you look at the recent failures in Cdm2 you will see the additional error message concerning the crash [@ mozilla::MediaManager::PostTask].

I've temporarily shut down Autophone due to problems caused by the change to gradle builds, but if you see Cmd2 failures with crash [@ mozilla::MediaManager::PostTask] in the future, those should be starred against bug 1412394.
58 failures in 143 pushes (0.406 failures/push) were associated with this bug yesterday.    

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* mozilla-central: 41
* mozilla-inbound: 17

Platform breakdown:
* android-7-1-armv8-api16: 17
* android-4-4-armv7-api16: 17
* android-6-0-armv8-api16: 13
* android-5-0-armv8-api16: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-11-02&endday=2017-11-02&tree=all
Whiteboard: [stockwell needswork] → [stockwell disable-recommended]
248 failures in 857 pushes (0.289 failures/push) were associated with this bug in the last 7 days. 

This is the #6 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **   

Repository breakdown:
* autoland: 86
* mozilla-central: 82
* mozilla-inbound: 80

Platform breakdown:
* android-4-4-armv7-api16: 89
* android-7-1-armv8-api16: 78
* android-6-0-armv8-api16: 63
* android-5-0-armv8-api16: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-10-30&endday=2017-11-05&tree=all
"Disabled" in that Cdm2 is not being run. No significant failures since Nov 2.
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
1 failures in 849 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* android-4-4-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-11-06&endday=2017-11-12&tree=all
2 failures in 744 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1
* mozilla-central: 1

Platform breakdown:
* android-7-1-armv8-api16: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-11-20&endday=2017-11-26&tree=all
13 failures in 792 pushes (0.016 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 9
* mozilla-central: 3
* mozilla-inbound: 1

Platform breakdown:
* android-4-4-armv7-api16: 6
* android-7-1-armv8-api16: 5
* android-5-0-armv8-api16: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-11-27&endday=2017-12-03&tree=all
9 failures in 889 pushes (0.01 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 5
* mozilla-central: 3
* mozilla-inbound: 1

Platform breakdown:
* android-7-1-armv8-api16: 8
* android-5-0-armv8-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-12-04&endday=2017-12-10&tree=all
4 failures in 423 pushes (0.009 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 3
* autoland: 1

Platform breakdown:
* android-7-1-armv8-api16: 3
* android-5-0-armv8-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-12-11&endday=2017-12-17&tree=all
8 failures in 590 pushes (0.014 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 2
* autoland: 2

Platform breakdown:
* android-7-1-armv8-api16: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-12-18&endday=2017-12-24&tree=all
2 failures in 147 pushes (0.014 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 2

Platform breakdown:
* android-7-1-armv8-api16: 1
* android-5-0-armv8-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2017-12-25&endday=2017-12-31&tree=all
7 failures in 462 pushes (0.015 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 3
* autoland: 3
* mozilla-inbound: 1

Platform breakdown:
* android-7-1-armv8-api16: 4
* android-5-0-armv8-api16: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2018-01-01&endday=2018-01-07&tree=all
6 failures in 788 pushes (0.008 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 3
* autoland: 3

Platform breakdown:
* android-7-1-armv8-api16: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2018-01-08&endday=2018-01-14&tree=all
1 failures in 657 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* android-5-0-armv8-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2018-01-15&endday=2018-01-21&tree=all
2 failures in 701 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 2

Platform breakdown:
* android-6-0-armv8-api16: 1
* android-5-0-armv8-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393878&startday=2018-01-22&endday=2018-01-28&tree=all

Comment 22

10 months ago
Please note that unit testing on Autophone has been disabled everywhere but on try. You can select these tests via autophone-crashtest-dom-media-tests
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: REOPENED → RESOLVED
Last Resolved: a year ago9 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.