Closed Bug 1393883 Opened 2 years ago Closed 2 years ago

Update follow-on search add-on to 0.9.3

Categories

(Firefox :: Search, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Whiteboard: [fxsearch] [go-faster-system-addon] )

Attachments

(1 file)

We want to push the latest version of the follow-on search add-on to nightly.

https://github.com/mozilla/followonsearch/releases/tag/v0.9.3

This includes:

- Correct Google follow-tracking, regressed by the removal of Google Instant Search
Comment on attachment 8901275 [details]
Bug 1393883 - Update follow-on search add-on to 0.9.3.

https://reviewboard.mozilla.org/r/172728/#review178152
Attachment #8901275 - Flags: review?(past) → review+
Pushed by pastithas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/69e69689ddbe
Update follow-on search add-on to 0.9.3. r=past
Whiteboard: [fxsearch] [go-faster-system-addon]
Depends on: 1386658
Comment on attachment 8901275 [details]
Bug 1393883 - Update follow-on search add-on to 0.9.3.

Approval Request Comment
[Feature/Bug causing the regression]: Follow-on search telemetry.
[User impact if declined]: N/A The telemetry we're currently receiving is wrong due to a change in how Google are doing their searches.
[Is this code covered by automated tests?]: Currently manual
[Has the fix been verified in Nightly?]: I downloaded an autoland build and tested it there.
[Needs manual test from QE? If yes, steps to reproduce]: This will be getting testing as part of bug 1394083 as well.
[List of other uplifts needed for the feature/fix]: Bug 1386658
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small change to an object so that the tracking is restored.
[String changes made/needed]: None
Attachment #8901275 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/69e69689ddbe
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Doesn't apply to beta:
grafting 419454:69e69689ddbe "Bug 1393883 - Update follow-on search add-on to 0.9.3. r=past"
merging browser/extensions/followonsearch/content/followonsearch-fs.js
merging browser/extensions/followonsearch/install.rdf
 warning: conflicts while merging browser/extensions/followonsearch/install.rdf! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(standard8)
Did you apply bug 1386658 first? If there's stil an issue I can take a look at it later.
Flags: needinfo?(standard8)
Sorry, this is our bot failing, sorry
Comment on attachment 8901275 [details]
Bug 1393883 - Update follow-on search add-on to 0.9.3.

Fix collecting telemetry data. Beta56+.
Attachment #8901275 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Priority: -- → P1
Comment on attachment 8901275 [details]
Bug 1393883 - Update follow-on search add-on to 0.9.3.

Approval Request Comment

For most details, see comment 7.

Requesting uplift alongside bug 1386658 as this shipped as a system add-on update and should be included in the next 55 dot release if there is one.
Attachment #8901275 - Flags: approval-mozilla-release?
Comment on attachment 8901275 [details]
Bug 1393883 - Update follow-on search add-on to 0.9.3.

m-r is going to be 56 later today, no plans for another 55 dot release, so we'll skip this.
Attachment #8901275 - Flags: approval-mozilla-release? → approval-mozilla-release-
You need to log in before you can comment on or make changes to this bug.