support for "default_popup" of the manifest.json key browser_action

RESOLVED DUPLICATE of bug 1370333

Status

()

Toolkit
WebExtensions: Android
RESOLVED DUPLICATE of bug 1370333
3 months ago
3 months ago

People

(Reporter: ramkumar.kr94, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170816210634

Steps to reproduce:

1. Install the extension https://github.com/mdn/webextensions-examples/tree/master/beastify on android. (A signed version can be found in https://addons.mozilla.org/en-US/firefox/addon/beastify-test/?src=search)

2. Click on the browser action


Actual results:

There was no popup or a tab opened which contains the popup content defined in the manifest


Expected results:

A popup or a tab opened which contains the popup content defined in the manifest
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

3 months ago
Component: General → WebExtensions: Android
Product: Firefox for Android → Toolkit

Comment 1

3 months ago
I'm marking this bug as a duplicate of Bug 1370333, which has introduced support for both the browser_action.default_popup manifest property and the browser.browserAction.setPopup/getPopup API methods.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370333
You need to log in before you can comment on or make changes to this bug.