Print or Save 2nd tab operates on first tab

VERIFIED WORKSFORME

Status

SeaMonkey
Tabbed Browser
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: dadanada, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

One of my browser windows has 2 tabs open.  I'm viewing the 2nd tab.  I select
either File | Print or File | Save Page As... and the browser prints/saves the
contents of tab 1 instead of tab 2.

Reproducible: Always
Steps to Reproduce:
1. Login to some web site using SSL (I used Travelocity.com). 
2. Ctrl-click on something to open a page in 2nd tab.
3. Using the 2nd tab independently, login to e.g. yahoo mail account.
4. Print or save the 2nd tab.  First page is printed or saved.

Actual Results:  Page displayed in first tab is printed/saved, even though the
tab is not active.

Expected Results:  Print/Save the page that is actually displayed (tab 2).

In trying to reproduce I found loging out in first tab and then back in again
caused 2nd tab to not be saveable. File | Save As on 2nd tab brings up message
box titled "Save Link"  "The link could not be saved. The web page might have
been removed or had its name changed."

Comment 1

15 years ago
WFM with 2002092308/trunk/win2k.

reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.2alpha)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 2

15 years ago
Cant reproduce with 1.2alpha
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
i haven't encountered this with recent trunk (comm) builds either. vrfy.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.