Sorting of Bookmarks doesn't work at all

VERIFIED FIXED in mozilla1.3final

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: TJ, Assigned: janv)

Tracking

({regression})

Trunk
mozilla1.3final
regression
Dependency tree / graph
Bug Flags:
blocking1.3b -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

Attachments

(2 attachments)

15.52 KB, image/gif
Details
fix
690 bytes, patch
jag (Peter Annema)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
dbaron
: approval1.3+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Steps to reproduce

1) Bookmarks -> Manage Bookmarks...
2) Try to sort the bookmarks

Expected result: Bookmarks should sort.

Actual result: Bookmarks didn't change, regardless of which sort type.

Comment 1

15 years ago
There are several realted bugs: bug 64272, bug 64768,  bug 77411, bug
119905. 

However: Sorting by columns in bookmark manager WFM, XP, 2002041903.

Comment 2

15 years ago
Reporter: Was this a clean install (after an uninstall of older version of Mozilla)
Also: Can you add the build ID, please.
(Reporter)

Comment 3

15 years ago
I didn't unintsall 0.9.9, I just installed over it.
Sorry, thought I had this in the original bug,
Build ID: 2002041711 (RC1)

Comment 4

15 years ago
This happens to me in 1.0RC1, Windows 2000, fresh install. The bookmarks side
bar is sorted alpha, which is cool, but I can't get the Bookmarks menu to sort
at all (and DnD doesn't work right when sorting manually, see <a
href=http://bugzilla.mozilla.org/show_bug.cgi?id=114606>114606</a>.

Annoying!!

Comment 5

15 years ago
my 0.02$ :-)

When I want Mozilla to sort in A-Z order my bookmarks, it doesn't do anything.
Even selecting content of a folder.

Using build 2002042708 WinXP (latest folder).
*** Bug 142164 has been marked as a duplicate of this bug. ***
Confirming.  This does not work after startup until I click on one of the column
headers in bookmarks manager.  Then it starts working....  Until I have clicked
a column header, opening the View menu gives the following error in the JS console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.js :: fillViewMenu :: line
117"  data: no]

and actually picking a sort option gives:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.js ::
onViewMenuSortItemSelected :: line 152"  data: no]
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 8

15 years ago
Created attachment 83474 [details]
Screenshot of not sorted bookmarks in RC2

Screenshot of not sorted bookmarks in RC2

Comment 9

15 years ago
*** Bug 146652 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Clean installation of RC3. Problem occurred on my RC2 but I uninstalled completely and it still 
manifests itself.

Comment 11

15 years ago
sort doesn't work in RC3 either - needs fixing before 1.0!

Comment 12

15 years ago
Absolutely! Hate the way the Bookmarks system is set up. Why two different ways
to access it  --  Manage Bookmarks (which doesn't manage very well) and the
Sidebar list which cannot be sorted other than alphanumeric? It's confusing. If
it can be managed to change the sort in Manage Bookmarks, it does not carry to
the sidebar list. No way to directly sort the sidebar list. This is frustrating.

Comment 13

15 years ago
*** Bug 150844 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 151307 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 151645 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 144741 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
*** Bug 155606 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
*** Bug 156741 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
*** Bug 158276 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: mozilla1.2

Updated

15 years ago
Blocks: 154968

Comment 20

15 years ago
*** Bug 161454 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Still see this behavior in Trunk Build of September 1st 2002 :-(

Updated

15 years ago
Keywords: regression

Comment 22

15 years ago
*** Bug 166661 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: nsbeta1
*** Bug 168683 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
clean install of 1.1 - still not resolved.
a-z ordering works for me, but only under "manage bookmarks", not in the actual
menu tab. there it's still unsorted.

Comment 25

15 years ago
*** Bug 145431 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
*** Bug 170491 has been marked as a duplicate of this bug. ***

Comment 27

15 years ago
This is still broken, but in Phoenix it works. 

Comment 28

15 years ago
This doesnt seem to work on Phoenix 0.2 neither on Linux

Comment 29

15 years ago
sorting worked in Phoenix 0.1 and I loved it, but now with Phoenix 0.2 it
doesn't work anymore just like in Mozilla.

Comment 30

15 years ago
This is very weird, because it works for me in Phoenix 0.2 and not in Mozilla.

Comment 31

15 years ago
it works in both moz 1.1 and phoenix 0.2  in the "manage bookmarks" window, but
in  none of them if you i just click boomarks.

Comment 32

15 years ago
Works for me in 1.1 de-AT WinME, BUT the sorting is A-Z and then again a-z, do
not think that that is sensible. Also as filed in other bugs, folders should
definitly not be sorted, but put at the top.

Comment 33

15 years ago
Nav triage team: nsbeta1+/adt1
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]

Comment 34

15 years ago
Dont get the javascript errors anymore. And also I can sort the bookmarks in the
"Manage bookmarks", but then when you check your bookmarks they are NOT sorted.

Comment 35

15 years ago
*** Bug 175367 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
*** Bug 141014 has been marked as a duplicate of this bug. ***

Comment 37

15 years ago
*** Bug 178027 has been marked as a duplicate of this bug. ***

Comment 38

15 years ago
*** Bug 154968 has been marked as a duplicate of this bug. ***

Comment 39

15 years ago
*** Bug 178229 has been marked as a duplicate of this bug. ***

Comment 40

15 years ago
*** Bug 172715 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 172715
*** Bug 178911 has been marked as a duplicate of this bug. ***

Comment 42

15 years ago
Sorting by clicking column headings worked for the sidebar but has no effect on
the bookmarks menu. This is using build 2002101612 (v1.2b) downloaded and
installed today as upgrade over version 1.1, on WinXP Professional.

Comment 43

15 years ago
*** Bug 149450 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: mozilla1.3, nsCatFood
*** Bug 182075 has been marked as a duplicate of this bug. ***

Comment 45

15 years ago
I too cannot sort bookmarks (inside created folders) in Moz 1.2 Win2KPro. Would
like to be able to do this like I used to in IE where all I have to do is click
on the folder name (to see it's contents) then right-click and "Sort By Name."
Also, It's annoying to have to enter "Manage Bookmarks" to sort considering one
adds new bookmarks daily.

Comment 46

15 years ago
You can sort them directly when adding a new bookmark by going

Bookmarks -> File Bookmarks ...

The Keyboard Shortcut is CTRL+SHIFT+D

Updated

15 years ago
Flags: blocking1.3b?
*** Bug 185261 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.3b? → blocking1.3b-

Comment 48

15 years ago
*** Bug 185973 has been marked as a duplicate of this bug. ***
*** Bug 187470 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 50

15 years ago
reassigning
Assignee: ben → varga

Comment 51

15 years ago
I would just like to add that I think a very nice feature would be to have the
option "always sort by:" that will sort all your bookmarks automatically.

Example: "always sort by: alphabetical order a-z", "always sort by: date", etc.
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4alpha

Comment 52

15 years ago
There is a work-around for this bug to avoid future javascript errors that are
mentioned in comment 7.

1. Go to /Bookmarks/Manage Bookmarks (looking at view menu will give the js-error)
2. Click on the "name" field 1 or 2 times

now the js-error will not appear anymore and you can sort your bookmarks via the
view menu.

Comment 53

15 years ago
The same for me...windows XP SP1 and all 1.3a nightly build since January 15th,
 and still in the 1.3b...

I reckon this is a critical thing, because favourite/bookmarks are a very basic
feature of a browser...and in that case, it doesn't work very well

I had to sort them manually, which is a shame, honnestly ;)

None of the sorting methods work...
(Assignee)

Comment 54

15 years ago
Created attachment 114669 [details] [diff] [review]
fix

Originally I wanted to get rid of the pref based mechanism to keep sorting in
sync across the product.
Anyway, this patch should fix the JS errors, so sorting now works as expected.
pch, thanks for pointing this out.
(Assignee)

Comment 55

15 years ago
Comment on attachment 114669 [details] [diff] [review]
fix

Note, this is a bit tricky, since sort direction will be cycled to "natural".
So default bookmark sorting is actually "unsorted".
Attachment #114669 - Flags: superreview?(sspitzer)
Attachment #114669 - Flags: review?(jaggernaut)
(Assignee)

Updated

15 years ago
Flags: blocking1.3?
Target Milestone: mozilla1.4alpha → mozilla1.3final

Comment 56

15 years ago
Comment on attachment 114669 [details] [diff] [review]
fix

r=jag
Attachment #114669 - Flags: review?(jaggernaut) → review+
Comment on attachment 114669 [details] [diff] [review]
fix

sr=sspitzer

seeking approval on jan's behalf.
Attachment #114669 - Flags: superreview?(sspitzer)
Attachment #114669 - Flags: superreview+
Attachment #114669 - Flags: approval1.3?
Attachment #114669 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 58

15 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 59

15 years ago
Please note that this bug is not about sorting bookmarks in bookmarks menu.
That is bug 77411.

Updated

15 years ago
Flags: blocking1.3?
able to sort bookmarks in bookmarks mgr window. vrfy'd with 2003.02.19 comm
trunk bits.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.