Intermittent toolkit/content/tests/browser/browser_default_image_filename.js | Test timed out -

RESOLVED FIXED in Firefox -esr60

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: intermittent-bug-filer, Assigned: Paolo)

Tracking

({intermittent-failure})

unspecified
Firefox 63
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 fixed, firefox62 fixed, firefox63 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
This bug has failed 33 times in the last 7 days on all platforms and all build types.

Here is a recent log:
https://treeherder.mozilla.org/logviewer.html#?job_id=193699144&repo=autoland

TEST-UNEXPECTED-FAIL | toolkit/content/tests/browser/browser_default_image_filename.js | Test timed out - 
[task 2018-08-13T18:47:38.369Z] 18:47:38     INFO - GECKO(10167) | MEMORY STAT | vsize 2245MB | residentFast 320MB | heapAllocated 121MB
[task 2018-08-13T18:47:38.370Z] 18:47:38     INFO - TEST-OK | toolkit/content/tests/browser/browser_default_image_filename.js | took 45018ms
[task 2018-08-13T18:47:38.371Z] 18:47:38     INFO - checking window state
[task 2018-08-13T18:47:38.372Z] 18:47:38     INFO - TEST-START | toolkit/content/tests/browser/browser_default_image_filename_redirect.js
[task 2018-08-13T18:48:23.048Z] 18:48:23     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-08-13T18:48:23.050Z] 18:48:23     INFO - Buffered messages logged at 18:47:37
[task 2018-08-13T18:48:23.051Z] 18:48:23     INFO - Entering test bound 
[task 2018-08-13T18:48:23.052Z] 18:48:23     INFO - Buffered messages logged at 18:47:38
[task 2018-08-13T18:48:23.054Z] 18:48:23     INFO - Redirecting: http://mochi.test:8888/browser/toolkit/content/tests/browser/firebird.png
[task 2018-08-13T18:48:23.055Z] 18:48:23     INFO - Buffered messages finished
[task 2018-08-13T18:48:23.056Z] 18:48:23     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/browser/browser_default_image_filename_redirect.js | Test timed out - 
[task 2018-08-13T18:48:23.066Z] 18:48:23     INFO - GECKO(10167) | MEMORY STAT | vsize 2234MB | residentFast 307MB | heapAllocated 117MB
[task 2018-08-13T18:48:23.067Z] 18:48:23     INFO - TEST-OK | toolkit/content/tests/browser/browser_default_image_filename_redirect.js | took 45090ms
[task 2018-08-13T18:48:23.068Z] 18:48:23     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-08-13T18:48:23.069Z] 18:48:23     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/browser/browser_default_image_filename_redirect.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/toolkit/content/tests/browser/doggy.png - 
[task 2018-08-13T18:48:23.132Z] 18:48:23     INFO - checking window state
[task 2018-08-13T18:48:23.156Z] 18:48:23     INFO - TEST-START | toolkit/content/tests/browser/browser_f7_caret_browsing.js
[task 2018-08-13T18:49:08.196Z] 18:49:08     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-08-13T18:49:08.199Z] 18:49:08     INFO - Buffered messages logged at 18:48:23
[task 2018-08-13T18:49:08.201Z] 18:49:08     INFO - Entering test bound checkTogglingCaretBrowsing
[task 2018-08-13T18:49:08.202Z] 18:49:08     INFO - Buffered messages finished
[task 2018-08-13T18:49:08.205Z] 18:49:08     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/browser/browser_f7_caret_browsing.js | Test timed out - 
[task 2018-08-13T18:49:08.207Z] 18:49:08     INFO - GECKO(10167) | MEMORY STAT | vsize 2231MB | residentFast 304MB | heapAllocated 114MB
[task 2018-08-13T18:49:08.209Z] 18:49:08     INFO - TEST-OK | toolkit/content/tests/browser/browser_f7_caret_browsing.js | took 45045ms
[task 2018-08-13T18:49:08.210Z] 18:49:08     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-08-13T18:49:08.211Z] 18:49:08     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/browser/browser_f7_caret_browsing.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,Caret browsing is fun.<input id='in'> - 
[task 2018-08-13T18:49:08.275Z] 18:49:08     INFO - checking window state
[task 2018-08-13T18:49:08.299Z] 18:49:08     INFO - TEST-START | toolkit/content/tests/browser/browser_findbar.js

:Paolo Amadini: Can you please take a look at this bug?
Flags: needinfo?(paolo.mozmail)
Whiteboard: [stockwell needswork]
Assignee

Comment 49

9 months ago
The issue is that the "img" element is not ready when we want to use it. Trying one fix option here:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=793332969afda64cb1d64d91737a29a925e91572
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7f37db672df4b37630e684b51f0bcbee9e71b622
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Flags: needinfo?(paolo.mozmail)
Priority: P5 → P1
Comment hidden (Intermittent Failures Robot)
Comment on attachment 9002430 [details]
Bug 1393965 - Fix intermittent browser_default_image_filename.js. r=mconley

Mike Conley (:mconley) (:⚙️) has approved the revision.
Attachment #9002430 - Flags: review+

Comment 55

9 months ago
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b43dff21dd79
Fix intermittent browser_default_image_filename.js. r=mconley

Comment 56

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b43dff21dd79
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.