Caret does not reach first line first position when pressing ctrl-left arrow in a TEXTAREA

RESOLVED FIXED in Future

Status

()

Core
Selection
--
minor
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: Johannes Almiala, Assigned: mjudge)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
Future
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
While I tested bug 82151 I found another oddity. Control and left arrow does no
reach the first empty rows. 

To reproduce: Press enter a few times in the additional comments field in
bugzilla. Then enter some text. Use control-left arrow to go back to beginning
word by word.

Expected result: Caret should reach beginning of the first line.

What happens: Caret stops at the beginning of the first line that has text in it.
(Reporter)

Comment 1

16 years ago
changed description.
Summary: Caret does not reach first line first position when pressing ctrl-left arrow if line is empty → Caret does not reach first line first position when pressing ctrl-left arrow in a TEXTAREA

Comment 2

16 years ago
--> mjudge (caret/selection navigation)
Assignee: rods → mjudge
Component: HTML Form Controls → Selection

Updated

16 years ago
Target Milestone: --- → mozilla1.1alpha

Comment 3

16 years ago
Seeing on linux too.
Confirming.

It's rather minor bug, because you can use other keys to navigate the caret to
the beginning.
Blocks: 108120
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

15 years ago

dasl daslkj dsalk 

Comment 5

15 years ago
Oops, sorry for that.

I Just tested this bug and forgot to clear the comments field before CCing myself...

Prog.

Comment 6

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Updated

11 years ago
Blocks: 344417

Comment 7

11 years ago
Created attachment 237936 [details]
Testcase

Updated

11 years ago
Keywords: testcase
Fixed by the "phase 1" patch on bug 300131.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 300131
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.