Toolbar and menubar grippies can not be disabled.

RESOLVED FIXED in seamonkey2.55

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.55

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.53 fixed, seamonkey2.54 fixed, seamonkey2.55 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

I am a little twitchy with the mouse and constantly hide a toolbar via grippy when I really only want to click on "Home" or "Back". I have no use for the grippies anyway and would like to have an option to disable them.
Posted patch 1394106-grippyhide.patch (obsolete) — Splinter Review
This seems to kill them for good via pref.

If you have collaped a toolbar and then set the pref the collapsed state will still be shown. When you "uncollape" it the grippy is gone.

The pref could be exposed in the ui later but this would mean it need to be observed here. So to keep it simple I just added a pref. I don't think anyone would change it more than once during profile lifetime.
Attachment #8901455 - Flags: review?(iann_bugzilla)
Duplicate of this bug: 1400217
Posted patch 1394106-grippyhide-V2.patch (obsolete) — Splinter Review
The modern theme did show the toolbargrippy with the first patch because it didn't inherit the grippyhidden attribute from the superclass.
Attachment #8901455 - Attachment is obsolete: true
Attachment #8901455 - Flags: review?(iann_bugzilla)
Attachment #8908975 - Flags: review?(iann_bugzilla)
Because of how easy it is in glitchy old age to accidentally hit a grippy instead of the actual desired target, moving the pointer in the process if clicking, I've been using userChrome.css to hide grippies for something like 15 years.
Shouldn't the default for browser.toolbars.grippyhidden be defined in browser-prefs.js?
getBoolPref now takes an optional default so its not really needed. But would be easy to change the code.
If you want users to discover the new pref in about:config easily, define the default for it.
Otherwise, it's always effort to explain users how to create a new pref...
Comment on attachment 8908975 [details] [diff] [review]
1394106-grippyhide-V2.patch

I think it would be good to have a default in browser-prefs.js as suggested.
r=me with that change.
Attachment #8908975 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/763550197515
Enable hiding toolbar grippies via pref. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: user can't disable grippies
Testing completed (on m-c, etc.): c-esr c-r c-b
Risk to taking this patch (and alternatives if risky): simple patch.
String changes made by this patch: --

Default pref added and parameter for getBoolPref adjusted. r+ from IanN carried forward.

Can I have it in all branches? :)
Attachment #8908975 - Attachment is obsolete: true
Attachment #8914341 - Flags: review+
Attachment #8914341 - Flags: approval-comm-release?
Attachment #8914341 - Flags: approval-comm-esr52?
Attachment #8914341 - Flags: approval-comm-beta?
Target Milestone: --- → seamonkey2.55
Comment on attachment 8914341 [details] [diff] [review]
1394106-grippyhide-V3.patch

a=me
Attachment #8914341 - Flags: approval-comm-release?
Attachment #8914341 - Flags: approval-comm-release+
Attachment #8914341 - Flags: approval-comm-esr52?
Attachment #8914341 - Flags: approval-comm-esr52+
Attachment #8914341 - Flags: approval-comm-beta?
Attachment #8914341 - Flags: approval-comm-beta+
Fixed for 2.49.2
You need to log in before you can comment on or make changes to this bug.