reload button is tedious to access

RESOLVED DUPLICATE of bug 1401529

Status

()

Firefox for Android
General
P5
normal
RESOLVED DUPLICATE of bug 1401529
4 months ago
2 months ago

People

(Reporter: ultrafox, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

1. I want to reload a page in a tab.
2. I discover that there is no automatically visible button available on-screen.
3. I have to click the More (...) button and scroll up to find the reload button.

This is tedious.


Actual results:

The page reloaded, but only after having to hunt to find it.


Expected results:

As a user, I expect to be able to both (1) stop a page load and (2) reload a page very quickly with one tap.

I can tap the "X" button which appears on-screen in the URL bar during a page load to stop a page, so that's good.

But when I want to reload a page, I have to click the More (...) button and scroll up to find the reload button. This is tedious.

Can we not have an option to simply have a reload button in the space where the X (stop loading) button previously appeared?

Comment 1

4 months ago
On phones in portrait mode, space is tight enough as it is and any additional button that's permanently visible eats into the space for the URL itself, so it's always a trade-off. But...

(In reply to ultrafox from comment #0)
> ... and scroll up to find the reload button.

... on what phone/device are you seeing this? Normally, when the menu opens, it should be already be scrolled to the top such that the reload button is directly above the three-dot button. When this works, this means that you can effectively just tap the three-dot menu twice to reload (similar to how pressing the tab counter twice works for opening a new tab). Maybe you can provide a screen shot how the menu is looking for you immediately after pressing the menu button?
(Reporter)

Comment 2

4 months ago
Thanks, Jan, for this swift reply! Much appreciated.

The issue is that the menu that the three-dot button opens up remains scrolled to wherever it was scrolled last. So frequently, it just so happens that when I want to reload a page, the three-dot menu has been previously scrolled down. That's why I then have to scroll back up, which is tedious. 

I understand the need for screen real-estate. I would like to propose a couple alternatives for fixing the currently-irritating  reload feature:

1. (My favorite) Simply allow the user to customize the browser to put the reload button in the URL bar. As a user, I don't care if it occludes some of the URL because I prefer to have a one-tap reload. To me, this is straightforward and lets people do what they want.

2. (Second-best) I agree that you wouldn't want to plop the reload button into the URL bar for everyone (especially those with not-wide phones). I also have read the arguments against Google-Chrome-style swipe-down-to-reload and I have to agree that that would do more harm than it would help. But what about a more focused, intentional gesture, such as: Pull down on the three-dot button to reload (instead of tapping it to open the menu)?

Comment 3

3 months ago
What phone model/OS version are you seeing this behaviour on?
Flags: needinfo?(ultrafox)

Updated

3 months ago
See Also: → bug 1401529
(Reporter)

Comment 4

3 months ago
Sony Xperia XZ, Android 7.0 stock Sony build 33.3.A.0.131 (kernel 3.18.35+
Flags: needinfo?(ultrafox)

Comment 5

3 months ago
Hi Tori
Please advise
Flags: needinfo?(tchen)

Comment 6

3 months ago
I'd tend to regard this as a duplicate of bug 1401529, as the root cause is that we fail to reset the scroll position on some devices, where "some" so far seems to mean Sony.

Comment 7

2 months ago
Thanks for the suggestion. Due to the limited space, adding refresh button to url bar could be hard. Good news is that pull-to-refresh(similar) is something we want to do, too. I'll add PM to the cc list to track this bug.
Flags: needinfo?(tchen)

Comment 8

2 months ago
(fix typo)

Thanks for the suggestion. Due to the limited space, adding refresh button to url bar could be hard. Good news is that pull-to-refresh(similar to what chrome is doing) is something we want to do, too. I'll add PM to the cc list to track this bug.

Updated

2 months ago
Priority: -- → P5

Comment 9

2 months ago
Pull-to-refresh doesn't solve the problem when I am at the bottom of a long web page.  Then I have to scroll back up to the top of the web page to then be able to refresh.  Actually, it's literally introducing the same hassle if the answer is to be pull-to-refresh.  It would take a longer scroll if the web page is a long web page.

http://www.worldslongestwebsite.com/

If each new visitor added to the bottom of that web page and you were at the bottom of the page, you'd have to scroll back up to pull-to-refresh so you could reload the webpage to see new visitor.  Silly example but it proves the point.  The original quirk should be fixed to address the issue of the current refresh button scrolling out of view on long web pages.

Comment 10

2 months ago
Zte axon 7

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1401529
You need to log in before you can comment on or make changes to this bug.