All users were logged out of Bugzilla on October 13th, 2018

Intermittent dom/events/test/pointerevents/test_touch_action.html | Test timed out.

RESOLVED FIXED in Firefox 59

Status

()

P2
normal
RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: stone)

Tracking

({intermittent-failure})

unspecified
mozilla59
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [stockwell fixed:timing])

Attachments

(1 attachment)

1 failures in 908 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-08-21&endday=2017-08-27&tree=all
18 failures in 939 pushes (0.019 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 12
* mozilla-central: 4
* try: 2

Platform breakdown:
* linux32-stylo: 10
* linux64: 3
* linux64-stylo: 2
* linux32: 2
* linux64-stylo-sequential: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-08-28&endday=2017-09-03&tree=all
20 failures in 924 pushes (0.022 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* mozilla-central: 4
* try: 3
* mozilla-inbound: 2

Platform breakdown:
* linux32: 8
* linux32-stylo-disabled: 5
* linux32-stylo: 4
* linux64-stylo: 2
* linux64-stylo-sequential: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-09-04&endday=2017-09-10&tree=all
16 failures in 1032 pushes (0.016 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 6
* autoland: 5
* try: 3
* mozilla-release: 1
* mozilla-central: 1

Platform breakdown:
* linux32-stylo-disabled: 7
* linux32: 5
* linux64: 3
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-09-11&endday=2017-09-17&tree=all
18 failures in 943 pushes (0.019 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 8
* mozilla-central: 4
* mozilla-inbound: 3
* mozilla-beta: 3

Platform breakdown:
* linux32-stylo-disabled: 10
* linux32: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-09-18&endday=2017-09-24&tree=all
24 failures in 885 pushes (0.027 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 10
* mozilla-inbound: 8
* mozilla-central: 3
* mozilla-beta: 3

Platform breakdown:
* linux32: 12
* linux32-stylo-disabled: 9
* linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-09-25&endday=2017-10-01&tree=all
12 failures in 824 pushes (0.015 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 5
* mozilla-inbound: 4
* mozilla-central: 2
* mozilla-beta: 1

Platform breakdown:
* linux32-stylo-disabled: 7
* linux64: 3
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-10-02&endday=2017-10-08&tree=all
21 failures in 947 pushes (0.022 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 6
* mozilla-inbound: 5
* mozilla-central: 5
* mozilla-beta: 3
* try: 2

Platform breakdown:
* linux32-stylo-disabled: 11
* linux32: 9
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-10-09&endday=2017-10-15&tree=all
5 failures in 864 pushes (0.006 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 3
* mozilla-inbound: 1
* mozilla-esr52: 1

Platform breakdown:
* linux64: 4
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-10-16&endday=2017-10-22&tree=all
3 failures in 912 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2
* mozilla-release: 1

Platform breakdown:
* linux64: 2
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-10-23&endday=2017-10-29&tree=all
1 failures in 857 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* linux32-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-10-30&endday=2017-11-05&tree=all
2 failures in 849 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1
* mozilla-beta: 1

Platform breakdown:
* windows10-64-nightly: 1
* linux32-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-11-06&endday=2017-11-12&tree=all
1 failures in 762 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-11-13&endday=2017-11-19&tree=all
19 failures in 105 pushes (0.181 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 10
* mozilla-inbound: 7
* mozilla-central: 2

Platform breakdown:
* windows10-64: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-01&endday=2017-12-01&tree=all
Priority: P5 → --
Whiteboard: [stockwell needswork:owner]

Comment 15

11 months ago
This bug has failed 38 times in the last 7 days, Fails on Windows 10-64, build types are pgo and opt.

Here is a recent log:
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=149232626&lineNumber=5221

And here is a part of the log:

01:18:12     INFO -  Buffered messages logged at 01:13:12
01:18:12     INFO -  2855 INFO TEST-PASS | dom/events/test/pointerevents/test_touch_action.html | pointerevent_touch-action-inherit_parent-none_touch-manual.html | Synthesized vertical drag
01:18:12     INFO -  Buffered messages finished
01:18:12    ERROR -  2856 INFO TEST-UNEXPECTED-FAIL | dom/events/test/pointerevents/test_touch_action.html | Test timed out.
01:18:12     INFO -      reportError@SimpleTest/TestRunner.js:121:7
01:18:12     INFO -      TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
01:18:12     INFO -      TestRunner.runTests@SimpleTest/TestRunner.js:380:5
01:18:12     INFO -      RunSet.runtests@SimpleTest/setup.js:194:3
01:18:12     INFO -      RunSet.runall@SimpleTest/setup.js:173:5
01:18:12     INFO -      hookupTests@SimpleTest/setup.js:266:5
01:18:12     INFO -  parseTestManifest@http://mochi.test:8888/manifestLibrary.js:36:5

:overholt Can you please take a look at this bug?
Flags: needinfo?(overholt)
57 failures in 792 pushes (0.072 failures/push) were associated with this bug in the last 7 days. 

This is the #9 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 28
* mozilla-inbound: 15
* mozilla-central: 12
* try: 1
* mozilla-release: 1

Platform breakdown:
* windows10-64: 55
* windows10-64-nightly: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-11-27&endday=2017-12-03&tree=all
25 failures in 139 pushes (0.18 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 14
* mozilla-central: 6
* mozilla-inbound: 5

Platform breakdown:
* windows10-64: 24
* windows10-64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-04&endday=2017-12-04&tree=all
Stone knows pointer events best so hopefully he can find time to take a look.
Flags: needinfo?(overholt) → needinfo?(sshih)
Priority: -- → P2
28 failures in 178 pushes (0.157 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 9
* mozilla-inbound: 7
* mozilla-central: 7
* try: 5

Platform breakdown:
* windows10-64: 27
* windows10-64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-05&endday=2017-12-05&tree=all
24 failures in 157 pushes (0.153 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* mozilla-inbound: 10
* autoland: 7
* mozilla-central: 6
* try: 1

Platform breakdown:
* windows10-64: 23
* windows10-64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-06&endday=2017-12-06&tree=all
(Assignee)

Comment 21

10 months ago
The fail rate increased a lot recently. I'll check this in these days.
45 failures in 164 pushes (0.274 failures/push) were associated with this bug yesterday.    

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* mozilla-inbound: 19
* mozilla-central: 12
* autoland: 12
* try: 2

Platform breakdown:
* windows10-64: 44
* windows10-64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-08&endday=2017-12-08&tree=all
Whiteboard: [stockwell needswork:owner] → [stockwell disable-recommended]
179 failures in 889 pushes (0.201 failures/push) were associated with this bug in the last 7 days. 

This is the #2 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **   

Repository breakdown:
* mozilla-inbound: 62
* autoland: 58
* mozilla-central: 49
* try: 10

Platform breakdown:
* windows10-64: 174
* windows10-64-nightly: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-04&endday=2017-12-10&tree=all
(Assignee)

Comment 24

10 months ago
There are two problems with this intermittent failure. The failures are timeout when running pointerevent_touch-action-button-test_touch-manual.html and pointerevent_touch-action-inherit_highest-parent-none_touch-manual.html
Flags: needinfo?(sshih)
(Assignee)

Comment 25

10 months ago
Regarding the case about pointerevent_touch-action-button-test_touch-manual.html, found something [1] interesting. Here are partial logs.
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 0
11:32:40     INFO -  GECKO(2832) | InitTouchInjection ok
11:32:40     INFO -  GECKO(2832) | InjectTouchPoint
11:32:40     INFO -  GECKO(2832) | OnTouch
11:32:40     INFO -  GECKO(2832) | OnTouch touch move
11:32:40     INFO -  GECKO(2832) | OnTouch touch start

On Windows, we push preference 'apz.test.fails_with_native_injection' to true. However, the value is changed while synthesizing touch events for the test. This happened when the test failed. Synthesizing touch events by sending fake touch events can reduce the failure rate a lot.

[1] https://public-artifacts.taskcluster.net/E3otp40QSvKA-Rz7ThTRdw/0/public/logs/live_backing.log
20 failures in 70 pushes (0.286 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 9
* mozilla-inbound: 6
* mozilla-central: 5

Platform breakdown:
* windows10-64: 20

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-12&endday=2017-12-12&tree=all
(Assignee)

Comment 27

10 months ago
(In reply to Ming-Chou Shih [:stone] from comment #25)
> Regarding the case about
> pointerevent_touch-action-button-test_touch-manual.html, found something [1]
> interesting. Here are partial logs.
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 1
> 11:32:40     INFO -  GECKO(2832) | SynthesizeNativeTouchPoint 0
> 11:32:40     INFO -  GECKO(2832) | InitTouchInjection ok
> 11:32:40     INFO -  GECKO(2832) | InjectTouchPoint
> 11:32:40     INFO -  GECKO(2832) | OnTouch
> 11:32:40     INFO -  GECKO(2832) | OnTouch touch move
> 11:32:40     INFO -  GECKO(2832) | OnTouch touch start
> 
> On Windows, we push preference 'apz.test.fails_with_native_injection' to
> true. However, the value is changed while synthesizing touch events for the
> test. This happened when the test failed. Synthesizing touch events by
> sending fake touch events can reduce the failure rate a lot.
> 
> [1]
> https://public-artifacts.taskcluster.net/E3otp40QSvKA-Rz7ThTRdw/0/public/
> logs/live_backing.log

It seems the test case got scroll event, called async_test.done, and close the window before the chrome process handled all requests to synthesize touch events.
looking forward to this landing soon!
(Assignee)

Updated

10 months ago
Attachment #8936541 - Flags: review?(bugmail)
Attachment #8936541 - Flags: review?(bugmail) → review+
Duplicate of this bug: 1424202

Comment 31

10 months ago
Pushed by sshih@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d55477dfbd5a
Intermittent test_touch_action.html test timed out. r=kats.
20 failures in 92 pushes (0.217 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 8
* mozilla-inbound: 5
* mozilla-central: 5
* try: 2

Platform breakdown:
* windows10-64: 20

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-13&endday=2017-12-13&tree=all

Comment 33

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d55477dfbd5a
Status: NEW → RESOLVED
Last Resolved: 10 months ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59

Updated

10 months ago
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:timing]
60 failures in 423 pushes (0.142 failures/push) were associated with this bug in the last 7 days. 

This is the #12 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 19
* mozilla-inbound: 16
* mozilla-central: 15
* try: 10

Platform breakdown:
* windows10-64: 59
* windows10-64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2017-12-11&endday=2017-12-17&tree=all
(Assignee)

Updated

10 months ago
Blocks: 1394229
(Assignee)

Updated

10 months ago
Blocks: 1371671
1 failures in 814 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-esr52: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1394228&startday=2018-03-12&endday=2018-03-18&tree=all
You need to log in before you can comment on or make changes to this bug.