Inverted icons look faded and no longer have a shadow/border that provides contrast with certain lightweight themes

NEW
Unassigned

Status

()

P2
normal
a year ago
a year ago

People

(Reporter: crazypacman, Unassigned)

Tracking

({regression})

55 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 wontfix, firefox56- wontfix, firefox57 wontfix, firefox58 ?)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

I'm using the PurplePOL theme, which used to give interface buttons like home, favorites and the menu button a blue glow around them. After the automatic update tot 55.0.3 these icons are now bland white.


Actual results:

After the 55.0.3 update all interface buttons have their original style from Compact Dark (white, no border or glow).


Expected results:

Interface buttons should have the style as applied by the active FF theme (in my case white buttons with a blue glow).

Comment 1

a year ago
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
status-firefox55: --- → wontfix
status-firefox56: --- → affected
status-firefox-esr52: --- → unaffected
tracking-firefox56: --- → ?
Component: Untriaged → Theme
Ever confirmed: true
We should fix this regression in how themes work, but I don't think release management needs to track the bug. If we do land a fix on m-c, we can still take the patch on beta 56.
tracking-firefox56: ? → -
Keywords: regression
Dão, can you help find someone to fix this? Thanks!
Flags: needinfo?(dao+bmo)
It would be helpful if you had a screenshot to more accurately describe your problem and help indicate exactly what you're seeing.

PurplePOL appears to be a lightweight theme -- https://addons.mozilla.org/en-us/firefox/addon/purplepol/, so style is a generic browser style we apply plus the background images specific to that theme. AFAICT things are displayed as expected with a LWT, so I don't think there's anything to fix here.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dao+bmo)
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

a year ago
Created attachment 8909324 [details]
Theme icons in FF 54.0.1
(Reporter)

Comment 6

a year ago
Created attachment 8909326 [details]
Theme icons in FF 55.0.3
(Reporter)

Comment 7

a year ago
See added screenshots. It's visible that since FF 55 the shadow on UI icons is no longer present, which does not match the theme (and probably loads of other themes too).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

a year ago
Priority: -- → P3
Summary: GUI buttons no longer have a glow in 55.0.3 → Inverted icons look faded and no longer have a shadow/border that provides contrast with certain lightweight themes
Blocks: 1347543
Whiteboard: [photon-visual][triage]
I looked into adding a drop-shadow like this:

.toolbarbutton-1:-moz-lwtheme-darktext {
  filter: drop-shadow(0 0 1px white);
  text-shadow: none;
}

.toolbarbutton-1:-moz-lwtheme-brighttext {
  filter: drop-shadow(1px 1px 0 rgb(0,0,0,.5));
  text-shadow: none;
}

But this is too expensive and regresses lots of talos tests...

https://treeherder.mozilla.org/perf.html#/compare?originalProject=try&originalRevision=023222e374cfe1e0998584c00ab114ca51bebe1c&newProject=try&newRevision=0e270440634f672264e9b1ba73441d9de29bac78&framework=1&showOnlyConfident=1

https://treeherder.mozilla.org/perf.html#/compare?originalProject=try&originalRevision=023222e374cfe1e0998584c00ab114ca51bebe1c&newProject=try&newRevision=c03ff125dcd334bf40a25d89414cc33978a7d8a2&framework=1&showOnlyConfident=1
Status: REOPENED → NEW
Priority: P3 → --
Whiteboard: [photon-visual][triage]
Priority: -- → P2
Too late for a fix for 56/57. We could still take a patch in nightly.
status-firefox56: affected → wontfix
status-firefox57: --- → wontfix
status-firefox58: --- → ?
You need to log in before you can comment on or make changes to this bug.