Validate the output of the SHIELD study addon using the simulator

RESOLVED DUPLICATE of bug 1391664

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1391664
a year ago
a year ago

People

(Reporter: Dexter, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: [measurement:client])

(Reporter)

Description

a year ago
The SHIELD addon was developed and tested manually. The addon also comes with unit testing for the RAPPOR utility functions. However, it makes a lot of sense to validate the output of the addon using the simulator that was used in bug 1379195.

We could:

- Write a scratchpad script to make the addon generate data according to a known distribution.
- Pipe the output of the addon to the simulator.
- Make sure that the resulting distribution roughly matches the known ground truth.
(Reporter)

Updated

a year ago
Blocks: 1386566
Depends on: 1383757
Priority: -- → P2
Whiteboard: [measurement:client]
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391664
You need to log in before you can comment on or make changes to this bug.