The user should be able to move a downloaded file twice using drag and drop

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WONTFIX
6 months ago
4 months ago

People

(Reporter: Oana Botisan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
[Affected versions]:
- All Firefox builds

[Affected platforms]:
- Windows and macOS

[Steps to reproduce]:
1. Download something (ex: https://www.thinkbroadband.com/download)
2. Click on download icon from Toolbar 
3. Drag and drop the downloaded item on desktop.
4. Drag and drop again the downloaded item on desktop.

[Expected result]:
- You can copy the files twice. (And the location of the downloaded file doesn't change)

[Actual result]:
- You can drag and drop the file only ones. (And the location where the file is downloaded is changed.)

[Regression range]:
- It behaves the same even on Firefox 4.0.

[Additional notes]:
- This only happens on Windows and macOS.
- The reason I think that being able to drag and drop the files more then once is because maybe some users need a certain file more then once on their computer and this is much easier than downloading it several times. (As an example, if the user wants to modify the same picture and still have the original.)
- Another reason is that when you drag and drop the file, you can't find it if you right-click on it and select the option "Show in Folder" because the location of the file was changed. Which can be frustrating if you dragged and dropped the file by mistake somewhere.

Comment 1

4 months ago
One of the reasons why drag and drop cannot be done twice is that we don't know the target location of the move. I don't know if we could try to get this information, but this would likely be complex to do and platform-dependent anyways.

While we could probably try to create a copy of the file instead of moving it by default during drag and drop, this may not be what the user expects, and the duplicates may be a problem and slow to make especially for large downloads. So, I think the current default is the best we can do, even though the drawbacks listed in comment 0 are correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.