Sometimes mail messages ar e cut while sending

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: doofer-public, Assigned: bugzilla)

Tracking

({dataloss})

Trunk
Sun
Solaris
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9+) Gecko/20020417
BuildID:    2002041722

I am using solaris 8, and this has been happening for a few weeks worth of
builds now, though I couldn't tell you exactly when the first instance was.

Sometimes when I compose an email and try to copy / paste text in from a
terminal the paste will fail. Eventually the text will deceide it is going to
let itself be pasted (having tried select then middle mouse button paste, copy /
paste on the keyboard and trying to use paste within Mozilla (menu)).

The mail is received with the pasted item (usually a directory path, so they can
be quite long) cut, allong with everything following it. Also the mail is
corrupted in the same way in the sent folder.

Reproducible: Sometimes
Steps to Reproduce:
1. Feel lucky (or unlucky, depending on your viewpoint)
2. Compose a mail with a long pasted item (which took a lot of effort to paste.
3. Observe the corruption in sent / the received mail 

Actual Results:  Mail is cut off past the long, difficult to paste line.

Expected Results:  Sent the whole email :)

Updated

17 years ago
Severity: major → critical
Keywords: dataloss
(Reporter)

Comment 1

17 years ago
Using build 2002041722 I have turned on the debugging outputs. I just recreated
the bug. This is the output to the console at the time:

----- start output -----

./mozilla
Document http://slashdot.org/index.pl loaded successfully
Document http://slashdot.org/pollBooth.pl?qid=782&aid=5 loaded successfully
Document http://slashdot.org/index.pl loaded successfully
Document
http://www.google.com/search?q=operators+that+can+be+overloaded+c%2B%2B&sourceid=mozilla-search
loaded successfully
Document http://www.cplusplus.com/doc/tutorial/tut4-2.html loaded successfully
Document
http://www.google.com/search?q=operators+that+can+be+overloaded+c%2B%2B&sourceid=mozilla-search
loaded successfully
Document
http://www-staff.it.uts.edu.au/~kevin/teaching/31860/lectures/lecture6/slide11.html
loaded successfully
Document http://www.4p8.com/eric.brasseur/cppcen.html#l3 loaded successfully
Error loading URL ftp://xxxxxx@xxx.xxx.xxx.xxx/ : 804b0002
Document http://slashdot.org/index.pl loaded successfully
Error loading URL ftp://xxxxxx@xxx.xxx.xxx.xxx/ : 804b000e

ex = TypeError: gDBView has no properties
mailbox://xxxxxx@mailhost...skipping, already opened
mailCharsetLoadListener: ISO-8859-1 
[nsIMsgIdentity: id3],[nsIMsgIdentity: id1],[nsIMsgIdentity: id4]
XXX changed? false,true
SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id4]
Trying to position a sizeless window; caller should have called sizeToContent()
or sizeTo(). See bug 75649.

ComposeUnload from XUL

----- end output -----

I don't think the FTP is significant, so rather than publish my home IP and
username I have blanked it out. Also I have blanked out my username for my work
email account. The rest is intact.
can you still reproduce the problem with a recent mozilla build as 1.1beta?
(Reporter)

Comment 3

16 years ago
This is not something I have seen recently :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

16 years ago
OK, seen it again just now. I think it is a general Solaris 9 flaking out
problem because I had a terminal open (for weeks) that stopped accepting pastes
from the middle mouse button, but was OK for paste key pastes.

Comment 5

16 years ago
Verifying based on we have no reproducible case here in lab and reporter stated
it may be a general Solaris flakieness and resolve this as fixed.  Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.