Closed Bug 1394406 Opened 2 years ago Closed Last year

Input methods cannot commit characters in upper left search box at Facebook page

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 55
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zerngjia, Unassigned)

Details

(Keywords: inputmethod, Whiteboard: [platform-rel-Facebook])

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170823101153

Steps to reproduce:

Here I'm using Chinese input methods.

1. Open https://www.facebook.com/ and login
2. Try to type characters with input methods (such as 注音 input method on MacOS, or ibus-libzhuyin on GNU/Linux) in the upper left search box
3. It should detect the content you typed after you commit the candidates of the input method. Google Chrome, Vivaldi and Safari works well in this case.


Actual results:

1. On MacOS, the first key pressed in the input method is detected. However, after committing the candidates, no more thing happened. The search box gets the content only if extra key pressed such as arrow keys.
2. On GNU/Linux, nothing is detected in the process of typing with input methods. The search box gets the content only if extra key pressed such as arrow keys.


Expected results:

1. Within Google Chrome, Vivaldi and Safari browsers, the search box can find as you type on both MacOS and GNU/Linux platform. It searches as every keystroke types even in pre-edit text which not committed yet.
Keywords: inputmethod
Also reproduced in Firefox Developer Edition(56.0b6) on KDE neon User Edition 5.10, this bug appeared for quite a long time.

Workaround: Commit the pre-edit string and make a space keystroke to trigger the suggestions.
For your information, the Facebook page I opened here is in Traditional Chinese (Taiwan), 中文 (台灣), language.
I can reproduce this Bug on Windows Nightly (2017-08-25) on Windows 10, with Microsoft Phonetic/注音 (Trad. Chinese) and Microsoft IME (Japanese) on zh-TW Facebook. No similar issue is found on Chrome.

However when I switch Facebook to English version, the autocomplete feature for search box worked with both Chinese and Japanese IME. Can it be a Facebook problem?
Component: Untriaged → Desktop
Product: Firefox → Tech Evangelism
Version: 55 Branch → Firefox 55
Whiteboard: [platform-rel-Facebook]
I guess that Facebook uses keydown or keyup event to trigger the suggestions rather than input event. We've not fired keydown nor keyup events during composition yet, it's obviously a bug of Facebook since text may be inputted without keyboard, e.g., voice input and handwriting.
Tested today, the problem disappeared.

Other tests needed. If the problem is nothing to do with Firefox, we can close this bug then.
Priority: -- → P3
Indeed, the issue is no longer reproducible on Mac OS 10.13 and Nightly 61.
I'm not able to reproduce the issue either on Linux.

Tested with:
Browser / Version: Firefox Nightly 61.0a1 (2018-04-25)
Operating System: Linux Ubuntu 16.04
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.