Push Notifications can not be turned off

RESOLVED DUPLICATE of bug 1375683

Status

()

defect
RESOLVED DUPLICATE of bug 1375683
2 years ago
2 years ago

People

(Reporter: appacc2040, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170814142917

Steps to reproduce:

Go to any website that wants to push notifications to you.

Example: https://pushassist.com/knowledgebase/how-to-enable-or-disable-push-notifications-on-chrome-firefox-safari-b/

Firefox is using cached memory of the website to store the decision for push notifications.  So users in PRIVATE browsing mode OR who clear firefox memory on exit have to put up with these HORRIBLE NEW POPUPS that we all thought we got rid of in the 1990s!!!!

So it appears Firefox users have to make a choice:  A: Not protect their privacy or B) put up with popups on every site they go to.  And it won't long before EVERY website is abusing this HORRIBLE feature!



Actual results:

Dialog box pops up over URL every session even through I tell it to NOT send me push notifications.


Expected results:

Should not be popping up notifications.
Reporter

Comment 1

2 years ago
Firefox STILL shows push dialog on EVERY web page even though in about:config

dom.push.connection.enabled=false
dom.push.enabled=false
dom.push.http2.maxRetries=0
Reporter

Comment 2

2 years ago
This gets rid of push notification POPUPS:

dom.push.connection.enabled=false
dom.push.enabled=false
dom.webnotifications.serviceworkers.enabled=false
dom.webnotifications.enabled=false
Reporter

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Group: firefox-core-security
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1375683
You need to log in before you can comment on or make changes to this bug.