'Find' > 'Search Messages' disabled in Thunderbird Menu (aka hamburger aka appmenu) if no email is selected. Not consistent with menu bar.

RESOLVED FIXED in Thunderbird 57.0

Status

Thunderbird
Toolbars and Tabs
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: Anje, Assigned: Paenglab)

Tracking

52 Branch
Thunderbird 57.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170802111520

Steps to reproduce:

Using Windows Vista - not tested on other OS.
TB 52.3.0 

In Folder Pane
Select either mail account name OR a folder (but not an email)
via' Menu Bar': 'Edit' > 'Find' > 'Search Messages' is available.
via 'Mail toolbar': Menu icon' > 'Find' is disabled. 

If you select a folder and then select an email in the list to open email:
via' Menu Bar': 'Edit' > 'Find' > 'Search Messages' is available.
via 'Mail toolbar': Menu icon' > 'Find' >  'Search Messages' is available.



Actual results:

If you do not have the 'Menu Bar' enabled then you cannot use 'Search Messages' via 'Menu icon' unless you have opened an email because 'Find' offers no sub menu.

As a workaround :You can still use the method right click on folder > 'Search Messages' and then select to search on the account name.


Expected results:

via 'Mail toolbar': Menu icon' > 'Find' >  'Search Messages' being enabled should not depend upon opening an email. It should be auto available and enabled.
Comment hidden (obsolete)
(Reporter)

Comment 2

3 months ago
'Menu icon' = three horizontal lines icon.

Updated

3 months ago
Version: 45 Branch → 52 Branch
(Assignee)

Comment 3

3 months ago
Created attachment 8903941 [details] [diff] [review]
findMenu.patch

I changed the split menu to a normal menu. With this we have no more the functionality to click on "Find" and the searchbar appears but only a normal menu where you have to click on "Find" and then on "Find in This Message..." to show the searchbar. But the advantage is the menu is always enabled and the "Search Messages..." and the "Search Addresses..." are always accessible.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8903941 - Flags: review?(jorgk)

Comment 4

3 months ago
Comment on attachment 8903941 [details] [diff] [review]
findMenu.patch

Thanks, I had a personal demonstration ;-)
Attachment #8903941 - Flags: review?(jorgk) → review+
(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Comment 5

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/bf3e7a1f9092
Change the "Find" splitmenu to a normal menu. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

3 months ago
Target Milestone: --- → Thunderbird 57.0
You need to log in before you can comment on or make changes to this bug.