Unhandled exception when scrolling for folders

VERIFIED DUPLICATE of bug 13483

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 13483
18 years ago
13 years ago

People

(Reporter: ppandit, Assigned: scottputterman)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using a debug build on Sept. 15 1999 on Windows NT

1) Start apprunner
2) Bring up messenger
3) Click on email account
4) Folders appear
5) Start scrolling to get to the Inbox folder
6) Get an error: Unhandled exception in apprunner.exe (RAPTORHTML.DLL):
0xC0000005
7) This bug may be related to 13915 but that bug has a different trace

nsGenericElement::Release(nsGenericElement * const 0x03895058) line 1207 + 12
bytes
nsJSUtils::nsGenericResolve(JSContext * 0x0371f220, JSObject * 0x033d4580, long
15249540) line 556 + 12 bytes
ResolveElement(JSContext * 0x0371f220, JSObject * 0x033d4580, long 15249540)
line 165 + 17 bytes
_js_LookupProperty(JSContext * 0x0371f220, JSObject * 0x033d4580, long 25564560,
JSObject * * 0x0012ebac, JSProperty * * 0x0012eba4, const char * 0x00c6c00c,
unsigned int 1669) line 1507 + 24 bytes
js_GetProperty(JSContext * 0x0371f220, JSObject * 0x033d4580, long 25564560,
long * 0x0012f204) line 1669 + 35 bytes
js_Interpret(JSContext * 0x0371f220, long * 0x0012f384) line 2184 + 978 bytes
js_Invoke(JSContext * 0x0371f220, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x0371f220, JSObject * 0x033d3410, long 54342680,
unsigned int 1, long * 0x0012f4a0, long * 0x0012f508) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x0371f220, JSObject * 0x033d3410, long
54342680, unsigned int 1, long * 0x0012f4a0, long * 0x0012f508) line 2662 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x038cdec0) line 110 + 43 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012f8e0, nsIDOMEvent * * 0x0012f888, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 621 + 21 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x0380b5c0, nsIPresContext
& {...}, nsEvent * 0x0012f8e0, nsIDOMEvent * * 0x0012f888, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2881
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x03829850, nsIPresContext
& {...}, nsEvent * 0x0012f8e0, nsIDOMEvent * * 0x0012f888, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2885 + 39 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x03895bc0, nsIPresContext
& {...}, nsEvent * 0x0012f8e0, nsIDOMEvent * * 0x0012f888, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2885 + 39 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012f8e0,
nsIDOMEvent * * 0x0012f888, unsigned int 1, nsEventStatus &
nsEventStatus_eIgnore) line 789 + 39 bytes
AnonymousElement::HandleDOMEvent(AnonymousElement * const 0x0389504c,
nsIPresContext & {...}, nsEvent * 0x0012f8e0, nsIDOMEvent * * 0x00000000,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 130 + 31 bytes
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0x0381efa0, nsIPresContext & {...}, nsMouseEvent * 0x0012fbe4, nsEventStatus &
nsEventStatus_eIgnore) line 864 + 31 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x0381efa0,
nsIPresContext & {...}, nsGUIEvent * 0x0012fbe4, nsIFrame * 0x03887bf0,
nsEventStatus & nsEventStatus_eIgnore, nsIView * 0x03745d60) line 393 + 24 bytes
PresShell::HandleEvent(PresShell * const 0x03745944, nsIView * 0x03745d60,
nsGUIEvent * 0x0012fbe4, nsEventStatus & nsEventStatus_eIgnore) line 2024 + 43
bytes
nsView::HandleEvent(nsView * const 0x03745d60, nsGUIEvent * 0x0012fbe4, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 828
nsViewManager::DispatchEvent(nsViewManager * const 0x03744290, nsGUIEvent *
0x0012fbe4, nsEventStatus & nsEventStatus_eIgnore) line 1647
HandleEvent(nsGUIEvent * 0x0012fbe4) line 63
nsWindow::DispatchEvent(nsWindow * const 0x03745c24, nsGUIEvent * 0x0012fbe4,
nsEventStatus & nsEventStatus_eIgnore) line 332 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fbe4) line 353
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 3160 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line
3378
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 15794434, long *
0x0012fe04) line 2394 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00250370, unsigned int 514, unsigned int 0, long
15794434) line 401 + 27 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsAppShell::Run() line 74
nsAppShellService::Run(nsAppShellService * const 0x00ab5080) line 454
main1(int 1, char * * 0x00a41a40) line 555 + 12 bytes
main(int 1, char * * 0x00a41a40) line 578 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! BaseProcessStart@4 + 64 bytes
(Reporter)

Updated

18 years ago
QA Contact: lchiang → ppandit
(Reporter)

Comment 1

18 years ago
making ppandit the QA contact person

Updated

18 years ago
Assignee: phil → trudelle

Comment 2

18 years ago
Not sure if this is a hyatt bug or an evaughan bug, so I'll punt and start with
trudelle.

Updated

18 years ago
Assignee: trudelle → hyatt

Comment 3

18 years ago
I'm not sure either. Since evaughan is on vacation, I'll let hyatt get first
crack at it.

Comment 4

18 years ago
Is this similar to http://bugzilla.mozilla.org/show_bug.cgi?id=12645?

Comment 5

18 years ago
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).
(Assignee)

Updated

18 years ago
Assignee: hyatt → putterman
(Assignee)

Comment 6

18 years ago
this might be a dup, but I'll look into this.
(Assignee)

Updated

18 years ago
Blocks: 15008
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

18 years ago
*** This bug has been marked as a duplicate of 13483 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
verifying as duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.