Closed Bug 1394534 Opened 2 years ago Closed 2 years ago

Add ability to edit AS top sites titles and URLs (or add entirely custom top sites?)

Categories

(Firefox for Android :: Awesomescreen, enhancement)

All
Android
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1334175

People

(Reporter: mcomella, Unassigned)

Details

(Whiteboard: [mobileAS])

I spoke with bbell and he mentioned this is the eventual goal, though we recognize it may not come by 57. However, he mentioned this will help a address a lot of edge cases that our algorithms cannot perfectly address. In particular, we've been struggling with the naming to make sure all top sites are disambiguated, for example:
- bug 1391479: bbc.com vs. bbc.co.uk
- bug 1386902: use subdomain.domain in top sites
- bug 1390372: set top site title to page title if uri has a path
- bug 1389259: use screenshots to disambiguate sites
- bug 1393577: context menu leaves out information

All of the issues in these bugs could be addressed with editability, in addition to other user problems.

---

We used to have editability in top sites - I wonder if we can resurrect that code.

---

Adding to triage as an FYI but assume it'll go directly to P3.
fwiw, bbell feels this should be prioritized higher than the tablet work.
At least, as high as the tablet work. The tablet work shouldn't be daunting since it only entails widening the current view, so maybe we can do both.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334175
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.