Load AMD VP9 decoder using service ID

RESOLVED FIXED in Firefox 57

Status

()

Core
Audio/Video: Playback
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: jya, Assigned: jya)

Tracking

unspecified
mozilla57
x86
Windows
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
Currently the AMD VP9 decoder is loaded by manually looking for some DLLs and then searching for some symbols.
This is required because the VP9 decoder DLLs aren't registered with the system.

However AMD will modify their installer so that those DLLs will be registered.
We will then be able to load the decoding by using the CLSID just like we do with the Microsoft ones.
Comment hidden (mozreview-request)

Comment 2

6 months ago
mozreview-review
Comment on attachment 8902670 [details]
Bug 1394589: Load AMD VP9 decoder using CLSID.

https://reviewboard.mozilla.org/r/174340/#review179672
Attachment #8902670 - Flags: review?(cpearce) → review+

Comment 3

6 months ago
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f6ea847597a0
Load AMD VP9 decoder using CLSID. r=cpearce
https://hg.mozilla.org/mozilla-central/rev/f6ea847597a0
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.