website loops the first page

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Marco Mescalchin, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

looping between two index webpages

Reproducible: Always
Steps to Reproduce:
1.visit http://www.spacewalker.com/
Confirmed on linux.  Over to networking for investigation.
Assignee: attinasi → new-network-bugs
Component: Layout → Networking
OS: Windows XP → All
QA Contact: petersen → benc
Hardware: PC → All
The problem:
dafault.htm redirects to default.asp. 
default.asp contains:

var a=0;
if(a=0){
window.document.location.href="http://www.spacewalker.com/english/default.htm?"+
Math.random();
a=1;
}

So we are sent back to default.htm?123432
default.htm?123432 sends us to default.asp again. -> loop

Comment 3

16 years ago
Netscape 4.78 and IE 5.0 (on Win2K) don't have the problem.  They both load the
page as expected and in the end display this address in the url field.
http://www.spacewalker.com/english/default.asp

Moz RC1 (2002041711) on Win2K reproduces the problem.

Comment 4

16 years ago
Confrimed on Mac OS X. 

Just my quick analysis (and I don't know Javascript), but is the problem that
it's "if(a=0)"  instead of "if(a==0)" so a is always assigned 0? If so, that's
purely an issue with the script. If "if(a=0)" is the proper syntax in Javascript
(which I don't think it is), then this bug should be worked on. Else, this
should be marked INVALID.

Comment 5

16 years ago
cc for javascript help...

phil, any ideas?

Comment 6

16 years ago
takes me straight to http://www.spacewalker.com/index3.html
WFM 2002071608 win2k

Comment 7

16 years ago
Resolving as WORKSFORME. Using Mozilla trunk binaries 20020715xx
on WinNT, Linux, and Mac9.1.

Just as Michael reported above, Mozilla now is taken directly
to http://www.spacewalker.com/index3.html, no problems.

Choosing a country and entering the site also works fine.
It looks like they may have changed the HTML at the site.

bugzilla@meskatech.com: if you get a chance, could you try
the site again with an up-to-date Mozilla build? If the site
loads OK for you, could you mark this bug "Verified"?
Otherwise, you can reopen it; thanks -
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

16 years ago
from bugzilla@meskatech.com
I tried with build 2002071813
and works fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.