Can not access the Sync settings

RESOLVED DUPLICATE of bug 1391488

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1391488
5 months ago
5 months ago

People

(Reporter: Théo Salvini Tomaselli, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8902287 [details]
error-sync-1504018205224.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

Open settings and click on Sync


Actual results:

Can not access the Sync settings


Expected results:

Power access to the sync settings

Updated

5 months ago
Component: Untriaged → Sync
Summary: Sync → Can not access the Sync settings
> Error creating record: [Exception... "Could not convert Native argument arg 0 [nsIDNSService.myHostName]"  nsresult: "0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE)"  location: "JS frame :: resource://services-sync/util.js :: getDefaultDeviceName :: line 595"  data: no] Stack trace: getDefaultDeviceName()@resource://services-sync/util.js:595 < getDeviceName()@resource://services-sync/util.js:607 < get localName()@resource://services-sync/engines/clients.js:185 < createRecord()@resource://services-sync/engines/tabs.js:206 < _createRecord()@resource://services-sync/engines.js:954 < _uploadOutgoing()@resource://services-sync/engines.js:1646 < _sync()@resource://services-sync/engines.js:1800 < WrappedNotify()@resource://services-sync/util.js:160 < sync()@resource://services-sync/engines.js:723 < _syncEngine()@resource://services-sync/stages/enginesync.js:219 < sync()@resource://services-sync/stages/enginesync.js:166 < onNotify()@resource://services-sync/service.js:1081 < WrappedNotify()@resource://services-sync/util.js:160 < WrappedLock()@resource://services-sync/util.js:116 < _lockedSync()@resource://services-sync/service.js:1071 < sync/<()@resource://services-sync/service.js:1063 < WrappedCatch()@resource://services-sync/util.js:91 < sync()@resource://services-sync/service.js:1052

That seems suspicious. I'm curious what "Native argument arg 0" is...`myHostName` is a getter (https://searchfox.org/mozilla-central/rev/cd82cacec2cf734768827ff85ba2dba90a534c5e/netwerk/dns/nsDNSService2.cpp#1064-1073). o_O Also, I wonder if this is similar to bug 1391220.
There seems to be someone reporting a similar problem here:
https://www.reddit.com/r/firefox/comments/6x8tkj/why_are_my_sync_options_suddenly_barren/

He's running Fx 55.0.2 on Fedora 26 KDE. He thinks it happen right after updating from 55.
The reddit user found a solution. Turns out that in his case, it was related to a theme. I've asked to find out what theme caused the bug for him.
The theme in question for the above was Arc Darker: https://addons.mozilla.org/en-US/firefox/addon/arc-darker-theme/?src=ss

Others from the creator seem to be doing the same: https://addons.mozilla.org/en-US/firefox/user/horst3180/

Comment 5

5 months ago
I doubt the problem reported here is the same as that reddit thread - I suspect it's more of a coincidence given the stack.

If I simulate that error I see both failure to open sync setting and the same basic stacksyncing the clients engine, so I'm going to mark this as a dupe of bug 1391488.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391488
You need to log in before you can comment on or make changes to this bug.