Crash in `anonymous namespace''::handle_channel_layout

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
critical
Rank:
15
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: kinetik)

Tracking

({crash, regression, topcrash})

Trunk
mozilla57
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-590d894d-6b7b-478a-a073-2dc560170829.
=============================================================

Seen while looking at nightly crash data: http://bit.ly/2wPVOvQ. So far 41 crashes/11 installs on Windows.

Crashes started using 20170829100404. Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d10c97627b51a226e19d0fa801201897fe1932f6&tochange=1b4c59eef820b46eb0037aca68f83a15088db45f
Regressed by 1378070, bug this is a cubeb bug. I'll fix it tomorrow.
Assignee: nobody → padenot
Rank: 15
Depends on: 1378070
Priority: -- → P1
This has pretty high crash volume - 288 installs/1356 crashes.
Duplicate of this bug: 1395581
This signature is ranked #2 in content top-crashers.
Keywords: regression, topcrash
Alex, please link to the cubeb import bug that will have this fix
Flags: needinfo?(achronop)
Regression by 1378070, solved by 1395393.
URL: 1378070
Has Regression Range: --- → yes
Depends on: 1395393
No longer depends on: 1378070
Flags: needinfo?(achronop)
This is the #2 Windows topcrash in Nightly 20170901220209, and is not present in Nightly 20170902100317, yay.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Assignee: padenot → kinetik
Blocks: 1378070
URL: 1378070
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.