sidebar menus only show, does not toggle extension sidebars

VERIFIED FIXED in Firefox 57

Status

P3
normal
VERIFIED FIXED
a year ago
4 months ago

People

(Reporter: wcosta, Assigned: mixedpuppy)

Tracking

Trunk
mozilla57
x86_64
Mac OS X

Firefox Tracking Flags

(firefox55 wontfix, firefox56 affected, firefox57 verified)

Details

User Story

See bug 1387054 comment 5 for context.

Attachments

(2 attachments)

(Reporter)

Description

a year ago
+++ This bug was initially created as a clone of Bug #1387054 +++

Updated

a year ago
Component: Extension Compatibility → WebExtensions: Frontend
Priority: -- → P3
Product: Firefox → Toolkit
(Assignee)

Comment 1

a year ago
When moving to the new sidebar selector menu (bug 1365637) I changed the command to use SidebarUI.show rather than SidebarUI.toggle.  Need to simply change that back (iirc at first the new menu did not toggle).
Blocks: 1365637
Summary: Disabling sidebar doesn't work on nightly → view->sidebar->extension sidebar menu only shows, does not toggle
(Assignee)

Updated

a year ago
Summary: view->sidebar->extension sidebar menu only shows, does not toggle → sidebar menus only show, does not toggle extension sidebars
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Assignee: nobody → mixedpuppy
(Assignee)

Comment 3

a year ago
Comment on attachment 8906804 [details]
Bug 1394947 fix toggling the extension sidebars from menus,

Going to give this to Gijs since he reviewed the original change.
Attachment #8906804 - Flags: review?(tomica) → review?(gijskruitbosch+bugs)
(Assignee)

Updated

a year ago
status-firefox55: --- → wontfix
status-firefox56: --- → affected

Comment 4

a year ago
mozreview-review
Comment on attachment 8906804 [details]
Bug 1394947 fix toggling the extension sidebars from menus,

https://reviewboard.mozilla.org/r/178528/#review183700
Attachment #8906804 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 5

a year ago
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0ad97b0a82c4
fix toggling the extension sidebars from menus, r=Gijs
https://hg.mozilla.org/mozilla-central/rev/0ad97b0a82c4
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57

Comment 7

11 months ago
Created attachment 8928181 [details]
tabreduxopen.gif

Issue reproduced on Firefox 57.0a1 (20170828100127) under Wind 10 64-bit. 

This issue is verified as fixed on Firefox 57.0 (20171112125346), Firefox 58.0b3 (20171113130450) and 59.0a1 (20171113220112) under Wind 10 64-bit and Mac OS X 10.13.

Updated

11 months ago
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.