Cannot run 'arc diff' on commits with a commit message that contains the word 'bug'

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: mars, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
I created a commit with the following commit message:

'''
Add the repository callsign to .arcconfig                                       
                                                                                
See bug 1394049.      
'''

When I run 'arc diff' I get the following error:

'''
Commit message has errors:

      - Error parsing field "Subscribers": The objects you have listed
      include objects which do not exist (Bug:, 1394049).
      - Invalid or missing field "Bug #": Bugzilla Bug ID is required

You must resolve these errors to continue.

    Do you want to edit the message? [Y/n] 
'''

Workaround:  I deleted the word "bug" from the Summary section 'arc diff' created and 'arc diff' completed successfully.
I've been checking it in my local repo and no such thing happened.

In `arc diff` editor paragraph "see bug 123." automatically appeared in the Summary section.
Was this the case as well?
I also was unable to reproduce this bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.