New tab button color doesn't match tab close button color with some title bar colors

VERIFIED FIXED in Firefox 57

Status

()

Firefox
Theme
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: Filippo, Unassigned)

Tracking

(Blocks: 1 bug)

57 Branch
Firefox 57
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

(Whiteboard: [reserve-photon-visual] fixed by bug 1384686)

Attachments

(2 attachments)

(Reporter)

Description

4 months ago
Created attachment 8902582 [details]
Immagine.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170829100404

Steps to reproduce:

Open Firefox Nightly in Windows 10 with coloured title bar


Actual results:

With some title bar colors, "close tab" icon color and "new tab" icon color don't match (see attachment).


Expected results:

With some title bar colors, "close tab" icon color and "new tab" icon color should match.
(Reporter)

Updated

4 months ago
Blocks: 1325171
OS: Unspecified → Windows 10
(Reporter)

Updated

4 months ago
Component: Untriaged → Theme
Whiteboard: [photon-visual] [triage]
(Reporter)

Comment 1

4 months ago
Created attachment 8903481 [details]
Inverted situation

The same problem with inverted situation.
(Reporter)

Comment 2

3 months ago
[Tracking Requested - why for this release]: because this is a Photon theme bug and should be fixed.
status-firefox57: --- → ?
tracking-firefox57: --- → ?

Updated

3 months ago
Blocks: 1355767
No longer blocks: 1325171
Status: UNCONFIRMED → NEW
status-firefox57: ? → ---
tracking-firefox57: ? → ---
Ever confirmed: true
Priority: -- → P4
See Also: → bug 1384686
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]

Updated

3 months ago
Depends on: 1384686
See Also: bug 1384686

Updated

3 months ago
Duplicate of this bug: 1399832

Comment 4

3 months ago
Do you still see this?
Flags: needinfo?(filippo.mannino)
(Reporter)

Comment 5

3 months ago
(In reply to Dão Gottwald [::dao] from comment #4)
> Do you still see this?

No, now it works.
Flags: needinfo?(filippo.mannino)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Whiteboard: [reserve-photon-visual] → [reserve-photon-visual] fixed by bug 1384686
Target Milestone: --- → Firefox 57

Updated

3 months ago
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
Priority: P4 → P1

Comment 6

3 months ago
Marking verified based on comment 5.
Status: RESOLVED → VERIFIED
status-firefox57: --- → verified
Flags: qe-verify?
You need to log in before you can comment on or make changes to this bug.