Closed Bug 1395119 Opened 2 years ago Closed 25 days ago

Prefs not in libpref/init/all.js ignored

Categories

(Testing :: web-platform-tests, enhancement)

Version 3
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1485842

People

(Reporter: pehrsons, Unassigned)

References

Details

Per my findings in bug 1390521 comment 3 prefs set in wpt metadata (__dir__.ini or test.ini doesn't matter) are ignored unless they are already present in libpref/init/all.js.

We ran into this as we had consciously taken a decision to not expose a certain test-only pref to about:config.
Ah! Thanks for the investigation. I don't know much about how the prefs service works, but the code to inject prefs is called at [1] and the code to actually set a pref is [2]. So if I was guessing (which I am :) I would suggest that maybe only prefs in all.js have an associated type, so in your case we end up with a PREF_INVALID and so silently do nothing?

[1] http://searchfox.org/mozilla-central/source/testing/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py#193
[2] http://searchfox.org/mozilla-central/source/testing/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py#206
Flags: needinfo?(apehrson)
Status: NEW → RESOLVED
Closed: 25 days ago
Flags: needinfo?(apehrson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1485842
You need to log in before you can comment on or make changes to this bug.