Closed Bug 1395129 Opened 2 years ago Closed 2 years ago

mozcrash should more usefully display minidump pairs from CreateMinidumpsAndPair

Categories

(Testing :: Mozbase, enhancement)

Version 3
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1293270

People

(Reporter: ted, Unassigned)

Details

We very often see crashes in automation that are a result of our IPC code hitting a timeout and writing a pair of minidumps: one for the chrome process and one for the content process. The display of the stack traces in this case is very confusing, as the top of the stack of the chrome process is in Breakpad itself. bug 1395092 is a recent example. We should change mozcrash to recognize this situation and display some useful information, perhaps an additional output line stating that this is an IPC hang, and maybe even dumping the stack from the content process first?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293270
You need to log in before you can comment on or make changes to this bug.