Can't delete folders for other IMAP Servers

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Chris Webster, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031115

Deleting IMAP folders fails.  Dragging them to the Trash has no affect.

Reproducible: Always
Steps to Reproduce:
1.  Right click on folder and select delete.

Updated

16 years ago
QA Contact: olgam → huang
What is the error message?
this seems to be a dup of bug 119630.
(Reporter)

Comment 2

16 years ago
No error message.  Absolutly nothing happens.  I followed the link to bug 119630
and followed the directions listed (unselect sub-folders), but that had no effect.

Comment 3

16 years ago
same on Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0.0) Gecko/20020530
same on Mozilla/0.9.8 (Linux; Build 2002020511)

when deleting folder nothing happens; 

described bug only happens when no Trash Folder exists on IMAP-Server;
(A Trash folder is not necessary to exist if the option "When I delete a message"
is configured to "mark messages as deleted".)

IMAP-Server is UWASH 2001.315

Comment 4

16 years ago
I can reproduce this problem when using IMAP mark as deleted mode.
Nominating nsbeta1

Keywords: nsbeta1
Summary: Can't delete folders → Can't delete folders for IMAP mark as deleted mode

Comment 5

16 years ago
Updating this bug summary again since this bug original problem did describe
"Trash folder"
So, I think that this bug might be an IMAP interoperability bug.

For above delete folder of "mark as deleted" mode problem -> I have logged
another separate bug for tracking that problem (see bug 157809)

Reporter, can you try again with the latest build?
Since we have fixed bug 120485 for deleting folders recently....
Keywords: nsbeta1 → interop
Summary: Can't delete folders for IMAP mark as deleted mode → Can't delete folders for other IMAP Servers
(Reporter)

Comment 6

16 years ago
All appears well.  Deleting works.  Dragging to Trash makes a copy of the
folder, not sure of that is the intended affect.

Comment 7

16 years ago
Based on bug 120485 bug fix, resolving this bug as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
Marking as verified, please reopen this bug if you don't agree.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.