Allow a keyboard shortcut to be created for activating a web-extension

RESOLVED DUPLICATE of bug 1303384

Status

()

Toolkit
WebExtensions: General
RESOLVED DUPLICATE of bug 1303384
8 months ago
8 months ago

People

(Reporter: Greg, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 months ago
Created attachment 8902686 [details]
shortcut-1.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

Steps to reproduce:

Install an extension


Actual results:

Appears to not be possible to create a keyboard shortcut that activates the extension.


Expected results:

Like is possible on Google Chrome, it would be awesome to be able to create a keyboard shortcut that activates (or opens the UI) of an extension. For example, say I install the uMatrix extension by Raymond Hill. Once installed, I would like to create a keyboard shortcut (e.g., Ctrl+Shift+D or Alt+D, etc) that when pressed will open the uMatrix UI. This is a built-in capability that is possible in Google Chrome extensions. It would be awesome if Firefox had this too when it completes its web-extension transition.
(Reporter)

Comment 1

8 months ago
Created attachment 8902687 [details]
shortcut-2.png

Updated

8 months ago
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit

Comment 2

8 months ago
You can specify a command shortcut that calls the browser_action for an extension. Please see the Special Shortcuts on this page: 

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/commands

eg: _execute_browser_action. I think that should cover your needs. If you are talking about the ability to alter commands then thats bug 1303384.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303384
You need to log in before you can comment on or make changes to this bug.