Avoid an unnecessary copy of the display list by moving Finalization out of EndTranscation

RESOLVED DUPLICATE of bug 1405819

Status

()

RESOLVED DUPLICATE of bug 1405819
a year ago
11 months ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected)

Details

(Reporter)

Description

a year ago
We call PushBuiltDisplayList when we could probably just reuse the original. I'll do this after nical's reworking of transcations.
(Reporter)

Comment 1

a year ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #0)
> We call PushBuiltDisplayList when we could probably just reuse the original.
> I'll do this after nical's reworking of transcations.

Note, we currently add items to the builder after pushing_built, we'll need to resolve that first.
(Reporter)

Updated

a year ago
Depends on: 1382259
(Reporter)

Updated

a year ago
Depends on: 1395324
Priority: P3 → P2
Whiteboard: [wr-mvp]
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
(Reporter)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405819

Updated

11 months ago
Priority: P2 → --
Whiteboard: [wr-mvp]
You need to log in before you can comment on or make changes to this bug.