Missing `mach run` command in documentation

RESOLVED FIXED in Firefox 57

Status

defect
P5
trivial
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: arai, Assigned: abhinav.koppula)

Tracking

({good-first-bug})

unspecified
Firefox 57

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [dt-docs])

Attachments

(1 attachment)

Reporter

Description

2 years ago
https://hg.mozilla.org/mozilla-central/annotate/db7f19e26e571ae1dd309f5d2f387b06ba670c30/devtools/docs/getting-started/development-profiles.md#l18
> ./mach -P development

looks like the command lacks "run" or something that I'm not aware of
Thanks for reporting, this should be `./mach run -P development`.  Looks like that's also an issue on line 23 of the file.
Summary: wrong command in documentation → Missing `mach run` command in documentation
Whiteboard: [dt-docs]
Ahhh good catch, Tooru, Brian! thank you!

To fix this bug, `./mach -P development` must be replaced with `./mach run -P development` in lines 18 and 23 of file devtools/docs/getting-started/development-profiles.md
Keywords: good-first-bug
Assignee

Comment 3

2 years ago
patch with changes in development-profiles.md
Attachment #8903884 - Flags: review?(spenades)
Assignee

Comment 4

2 years ago
(In reply to Abhinav Koppula from comment #3)
> Created attachment 8903884 [details] [diff] [review]
> bz-1395295-mach-run.patch
> 
> patch with changes in development-profiles.md

:spenades - I have created a quick patch with the changes you mentioned. Please let me know if anything else is required.
Assignee: nobody → abhinav.koppula
Status: NEW → ASSIGNED
Priority: -- → P5
Comment on attachment 8903884 [details] [diff] [review]
bz-1395295-mach-run.patch

Many thanks! This looks good :)
Attachment #8903884 - Flags: review?(spenades) → review+

Comment 6

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9296a0739169
Use 'mach run' where it was intended in the DevTools documentation. r=sole
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9296a0739169
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.