Closed Bug 1395302 Opened 2 years ago Closed 2 years ago

<picture> element with hidpi srcset in <source> causes double width fo containing element

Categories

(Core :: DOM: CSS Object Model, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1149357

People

(Reporter: aryx, Unassigned)

Details

Attachments

(1 file)

Attached file testcase
A <picture> element with hidpi (2x) srcset in <source> causes double width for containing <div>. Replacing it with a low dpi (1x) image with half the width and length shows the image itself similar, but the containing element has the expected width.

Steps to reproduce:
1. Open the attached test case.
2. Move the mouse over the link text
Actual result: Mouse cursor doesn't indicate a link. Calling "Inspect Element" from the context menu selects <div class="image"> with a width of 1004 pixels (width of the embedded image).
Expected result: Mouse cursor indicates a link, <div class="image"> 502 pixels wide. (Actual result in Google Chrome 60.0.3112.113 and Inter Explorer 11.)
Priority: -- → P3
This looks like a dupe of bug 1385517, which was itself marked as a dupe of 1149357.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149357
You need to log in before you can comment on or make changes to this bug.