Closed Bug 1395369 Opened 2 years ago Closed 2 years ago

The stub installer progress bar retreats from 100% when it exits

Categories

(Firefox :: Installer, defect, P1)

All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: Abe_LV, Assigned: mhowell)

References

Details

Attachments

(1 file)

Steps  to reproduce:

Screen capture is here: https://testing-1.tinytake.com/sf/MTkxODAzMV82MTEyMDM0

1. Download stub installer from Mozilla-Central
2. Observe the progress bar 

Actual Result:
The progress bar retreats when the installer is about to exit.

Expected Result:
Progress bar should stay at 100% until the browser starts
Blocks: 1376597
Flags: needinfo?(mhowell)
There are a couple of things to be done about this:

1) Figure out how the bar is being allowed to reach 100% before the launch phase begins and fix that. This is the bug.
2) Set the bar to 100% in the "already running" path, just as a failsafe. This is not the real bug, but it would hide the problem from the user.
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Flags: needinfo?(mhowell)
Priority: -- → P1
It looks like during install ProgressCompleted is advancing every 100ms without limit in CheckInstall, so it passes the install end mark in 175 steps which is only 17.5 seconds, and fills up the bar completely in 20 seconds. Probably just clamp ProgressCompleted to PROGRESS_BAR_INSTALL_END_STEP, alternately make the install portion fill 10x slower to match with the 150/165 second install timeout (but that seems less desirable).
Thanks for taking a look, Adam. That analysis looks correct to me; patch that implements it incoming.
Comment on attachment 8903181 [details]
Bug 1395369 - Keep stub installer progress bar from filling too quickly.

https://reviewboard.mozilla.org/r/174968/#review180044
Attachment #8903181 - Flags: review?(agashlin) → review+
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ee88ddf08f4
Keep stub installer progress bar from filling too quickly. r=agashlin
https://hg.mozilla.org/mozilla-central/rev/7ee88ddf08f4
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Verified as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.