Crash when using two USB tokens on U2F test site

RESOLVED FIXED

Status

()

P1
major
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mwobensmith, Assigned: jcj)

Tracking

(Blocks: 1 bug)

Other Branch
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webauthn] [u2f], URL)

Attachments

(2 attachments)

With latest test build from 30-08-2017:

1. Visit https://demo.yubico.com/u2f
2. Insert two USB keys
3. Follow instructions to create account
4. Log in and touch token on prompt
** Note that token displays steady light instead of blinking light
5. Wait a few seconds
6. Attempt to interact with browser by refreshing page, etc.
** Note that browser is non-responsive.
7. Remove USB token that you interacted with and wait a few seconds, then reinsert.

Result: 
Crash


Note that between steps 6 and 7, you may experience a crash at intermittent times, as the previous steps appear to make Firefox unstable. I have attempted to find a case that crashes consistently.

Also note that test sites using WebAuthN and multiple tokens don't appear to have this problem.
(Assignee)

Comment 3

a year ago
Thanks, Matt! From the logs, this is probably crashing during the Cancel operation, which is not too surprising. In Bug 1245527 (which this test build uses), the U2FManager.cpp implementation is very, very close to the WebAuthn implementation -- however WebAuthn uses JS Promises, whereas U2F uses callbacks, and the state interactions with cancellation are a little different.

It'd make sense that we would have to treat them differently in the code.
Status: NEW → ASSIGNED
Depends on: 1245527
Priority: -- → P1
Whiteboard: [webauthn] [u2f]
(Assignee)

Comment 4

a year ago
I believe this may have been fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1245527#c22 ; I can no longer reproduce it locally, anyway.

When Bug 1245527 lands, I'll produce a new set of builds and we can try it again.
I think we can call this fixed, I can't reproduce it with Nightly. Matt? :)
Flags: needinfo?(mwobensmith)
Appears to be fixed, thanks Tim.
Flags: needinfo?(mwobensmith)
Cool, thanks Matt!
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.