add tooltips to sync preferences

RESOLVED FIXED in Firefox 59

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: glob, Assigned: rfeeley)

Tracking

Trunk
Firefox 59
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox59 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
some of the labels for the sync engines in sync preferences are not immediately clear what they refer to.

in particular "addresses" is ambiguous - web address?  email address?  street address?  i had to ask around to be told it's part of form fill's street/postal address stuff.

as naming things is hard, i propose adding tooltips to the sync preferences page explaining the type of data each option manages.
Ryan, WDYT, and assuming you agree, what strings do you propose? Also CC some of the autofill team for additional context.
Flags: needinfo?(rfeeley)
(Assignee)

Comment 2

2 years ago
Great idea! I've recently mocked this up for the Choose What To Sync screen during registration.

I've filed a copy request with Michelle.
Flags: needinfo?(rfeeley)
Priority: -- → P1

Comment 4

2 years ago
Good job with the doc.

If we're going to add tooltips in preferences I think we should consider some type of visual indicator (like the dashed line in the tour) otherwise many users may never discover them.
(In reply to Ryan Feeley [:rfeeley] from comment #3)
> Watch this space:
> https://docs.google.com/document/d/1xs17qfUE7YtB9Y6GyvG2O-myc5nc-
> cDoquIBbZc2rwU/edit?usp=sharing

I took the liberty of changing:

> [Preferences] Make your settings mostly the same on every device

to:

> [Preferences] Make your settings mostly the same on every Firefox desktop device

because preferences are ignored by all mobile devices. Please let me know if it should be changed back.

Also:

> [Add-ons] Extensions and themes for Firefox desktop

So there are now 2 strings which refer to "Firefox" - normally we avoid using the literal string Firefox and instead use the "brand" name - so Nightly is used on Nightly etc. However, I don't think that makes sense in this case - eg, a Nightly user seeing, say "Extensions and themes for Nightly desktop" might be mislead - the extensions and themes *would* be used if their other desktop device was on the release channel (ie, was "Firefox"). This will make life more difficult for other builds based on Firefox (eg, TOR, PaleMoon, etc) so I'm really not sure what the right thing to do there is.

(OTOH, those other builds are extremely unlikely to be including Sync anyway!)

Ryan, any thoughts?

(In reply to Caspy7 from comment #4)
> Good job with the doc.
> 
> If we're going to add tooltips in preferences I think we should consider
> some type of visual indicator (like the dashed line in the tour) otherwise
> many users may never discover them.

Yeah, I agree. However, I'm not sure we should miss 57 for that, so I'll have a quick play but will probably end up proposing this be done as a followup.
Flags: needinfo?(rfeeley)
Assignee: nobody → markh
Status: NEW → ASSIGNED

Comment 7

2 years ago
mozreview-review
Comment on attachment 8908783 [details]
Bug 1395453 - add tooltips to the sync engine names in about:preferences.

https://reviewboard.mozilla.org/r/180394/#review185578

LGTM. Let's wait on rfeeley's opinion on the wording before landing this.
Attachment #8908783 - Flags: review?(eoger) → review+
(Assignee)

Comment 8

2 years ago
I'm just back from PTO. We're still working on all the strings. I'll be meeting Alex tomorrow about it.
Flags: needinfo?(rfeeley)
(In reply to Ryan Feeley [:rfeeley] from comment #8)
> I'm just back from PTO. We're still working on all the strings. I'll be
> meeting Alex tomorrow about it.

needinfo to remind you, but we missed 57
Flags: needinfo?(rfeeley)
(Assignee)

Comment 10

2 years ago
We have strings, but they will require a new design, adding 6 more lines of copy on top of the tooltips. First run is more important than desktop prefs, but it would have been nice to get in in time. Not critical though.
Flags: needinfo?(rfeeley)
:rfeeley, how do you feel about helping :markh land this in 58? Do-able?

The design and copy you showed me yesterday for FxA registration flow seem like it could work for client side too.
Flags: needinfo?(rfeeley)
Assignee: markh → nobody
Status: ASSIGNED → NEW
Priority: P1 → P3
See Also: → 906647
Duplicate of this bug: 906647
(Assignee)

Comment 14

2 years ago
Here are the proposed tooltips. Kit, do you see any issues?

Bookmarks
Bookmarks and folders you’ve saved

History
Webpages you’ve visited

Open Tabs
A list of what’s open on all synced devices

Logins
Usernames and passwords you’ve saved

Addresses
Postal addresses you’ve saved (desktop only)

Credit Cards
Saved autofill credit card number and expiry date (desktop only)

Add-ons
Extensions and themes you’ve installed (desktop only)

Preferences (Mac) / Settings (Windows)
General, Privacy, and Security settings you’ve changed
Flags: needinfo?(rfeeley) → needinfo?(kit)
Thanks very much, Ryan! I have some suggestions and comments, which you're welcome to adopt or drop as you see fit. :-)

* History: on the first sync, Desktop only uploads the last 30 days of your history (bug 985930), and only up to 5000 unique URLs. I think Android does something similar, whereas iOS will eventually upload all your history (Grisha and Richard, please correct me if I'm wrong). This might be too pedantic...but I know other Mozilla folks have been confused why they don't see their full history on other devices when they connect a new device for the first time.

* Open Tabs: Suggest rewording as "Open tabs on all your devices". "What's open" sounds a bit ambiguous (especially since we only sync tabs, not windows), and "list" is more how it's presented, not what it is.

* Credit Cards: Maybe simplify to "Credit cards you've saved". You'll be able to have more than one, and we'll also sync the name on the card.

* Preferences: This one is tricky, though I think your description is about the best we can do without getting into minutiae. ("Some settings you've changed" is frustratingly ambiguous...even though it's totally accurate; the subset of the prefs we sync are more or less arbitrary!) It's also Desktop-only, and I think using different names (Preferences/Settings) on Mac, Windows, and Linux is inviting trouble.

In general: "Saved {bookmarks, usernames, addresses, ...}" reads more concisely than "{Bookmarks, usernames, addresses, ...} you've saved" to me, but I'm not a copy editor, so I'll trust your judgement!
Flags: needinfo?(kit) → needinfo?(rfeeley)
(In reply to Kit Cambridge (he/him) [:kitcambridge] (UTC-7) from comment #15)

> pedantic...but I know other Mozilla folks have been confused why they don't
> see their full history on other devices when they connect a new device for
> the first time.

See also Bug 1316110. On mobile we try to grab your most recent history and backfill.

Assuming we can handle the scale, I think it's worth revisiting Bug 985930.
For some context, Feeley worked with our copy writing team to come up with something that meets the restrictions we have on FxA and mobile too. (not to say there is no room to change but he put a lot of thought into this)

(In reply to Kit Cambridge (he/him) [:kitcambridge] (UTC-7) from comment #15)
> Thanks very much, Ryan! I have some suggestions and comments, which you're
> welcome to adopt or drop as you see fit. :-)
> 
> * History: on the first sync, Desktop only uploads the last 30 days of your
> history (bug 985930), and only up to 5000 unique URLs. I think Android does
> something similar, whereas iOS will eventually upload all your history
> (Grisha and Richard, please correct me if I'm wrong). This might be too
> pedantic...but I know other Mozilla folks have been confused why they don't
> see their full history on other devices when they connect a new device for
> the first time.
>

I think there's too many details here for a tooltip. We just want to clarify any uncertainty on the data type.

> * Open Tabs: Suggest rewording as "Open tabs on all your devices". "What's
> open" sounds a bit ambiguous (especially since we only sync tabs, not
> windows), and "list" is more how it's presented, not what it is.

The goal we had is to not use the word you're defining in the definition. So I like what Feeley is proposing.

> 
> * Credit Cards: Maybe simplify to "Credit cards you've saved". You'll be
> able to have more than one, and we'll also sync the name on the card.

That's pretty long.

> 
> In general: "Saved {bookmarks, usernames, addresses, ...}" reads more
> concisely than "{Bookmarks, usernames, addresses, ...} you've saved" to me,
> but I'm not a copy editor, so I'll trust your judgement!

Can't remember how we got there but I feel like there was a reason at the time. I think the point is emphasize it's what "you" save.
(In reply to Alex Davis [:adavis] [PM FxA+Sync] from comment #17)
> For some context, Feeley worked with our copy writing team to come up with
> something that meets the restrictions we have on FxA and mobile too. (not to
> say there is no room to change but he put a lot of thought into this)

Of course. My feedback wasn't meant to devalue the work that Ryan put into this, and I'm sorry it came across that way. We can land the tooltips as-is.
(In reply to Kit Cambridge (he/him) [:kitcambridge] (UTC-7) from comment #18)
> Of course. My feedback wasn't meant to devalue the work that Ryan put into
> this, and I'm sorry it came across that way. We can land the tooltips as-is.

Oh sorry! I didn't write that to disregard your feedback. In fact it was appreciated! Shows me you care. :) Also, Feeley wanted your feedback.

It was more meant to underline that Feeley gave this a lot of thought and consulted with many people. Ultimately, the copy wasn't just thrown out there. I wanted to make sure that it was clear.

That being said, since he is super busy right now, unless we have any big concerns with adding these (vs leaving nothing), I propose that we move forward with it so it doesn't have to do the round trip with the copy team again.

rfeeley: you initially intended to split these sync engines into categories to provide a value proposition. Is there a reason you removed it?
No worries at all, and understood! Moving forward with this sounds good to me.
(Assignee)

Comment 21

2 years ago
Our design systems group is opposed to tooltips on checkbox labels. They say the labels should be clear enough on their own. I'm trying to find a solution. Stay tuned.
Flags: needinfo?(rfeeley)
Priority: P3 → --
Assignee: nobody → rfeeley
Priority: -- → P2
(Assignee)

Comment 22

a year ago
OK: I worked with Michelle and we have decent tooltips, and a new order for the options.

Note that "Open Tabs" and "Credit Cards" are now "Open tabs" and "Credit cards".


COLUMN 1 of 2

Bookmarks (no tooltip)
History (no tooltip)
Open tabs – A list of what’s open on all synced devices
Logins – Usernames and passwords you’ve saved


COLUMN 2 of 2

Addresses – Postal addresses you’ve saved (desktop only)
Credit cards – Names, numbers and expiry dates (desktop only)
Add-ons – Extensions and themes you’ve installed (desktop only)
Preferences (Mac) / Settings (Windows) – General, Privacy, and Security settings you’ve changed


Good to go Kit?
Flags: needinfo?(kit)
LGTM! Mark, would you mind updating your patch, or should I?
Flags: needinfo?(kit) → needinfo?(markh)
Ryan, can you please clarify a couple of things:

(In reply to Ryan Feeley [:rfeeley] from comment #22)
> Addresses – Postal addresses you’ve saved (desktop only)
> Credit cards – Names, numbers and expiry dates (desktop only)
> Add-ons – Extensions and themes you’ve installed (desktop only)

So you want the literal "(desktop only)" to appear on the tooltip?

> Preferences (Mac) / Settings (Windows) – General, Privacy, and Security
> settings you’ve changed

In general, the term "Options" is used on Windows - eg:

https://searchfox.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.dtd#321-323
https://searchfox.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.dtd#706-708
https://searchfox.org/mozilla-central/source/browser/locales/en-US/chrome/browser/aboutHome.dtd#27-32

etc. So should this be "Options" instead of "Settings" on Windows?

I'll push a new version of the patch assuming "yes" to both the above, but let me know if I got it wrong.
Flags: needinfo?(markh) → needinfo?(rfeeley)
Comment hidden (mozreview-request)
(Assignee)

Comment 26

a year ago
Yes and yes.
Flags: needinfo?(rfeeley)
Comment on attachment 8908783 [details]
Bug 1395453 - add tooltips to the sync engine names in about:preferences.

Ed, do you mind taking another look please?
Attachment #8908783 - Flags: review+ → review?(eoger)

Comment 28

a year ago
mozreview-review
Comment on attachment 8908783 [details]
Bug 1395453 - add tooltips to the sync engine names in about:preferences.

https://reviewboard.mozilla.org/r/180394/#review206600

Assuming we're happy with the engine order/tooltips, LGTM!
Attachment #8908783 - Flags: review?(eoger) → review+

Comment 29

a year ago
Pushed by mhammond@skippinet.com.au:
https://hg.mozilla.org/integration/autoland/rev/01a9239a9885
add tooltips to the sync engine names in about:preferences. r=eoger

Comment 30

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/01a9239a9885
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.